Message: Whole screen becomes black or false-colored Not Logged In (login)
 Next-in-Thread Next-in-Thread
 Next-in-Forum Next-in-Forum

None Whole screen becomes black or false-colored 

Forum: (Graphical) User Interfaces
Date: 05 Apr, 2010
From: <sweber>

Hello!

I have a strange problem when using the openGL or openGL-Qt interface. My code (also any of the examples) compiles and runs without any errors.

But as soon as the openGL window comes into foreground the whole screen becomes almost black or changes to some false colors.

When another window is brought to foreground the screen turns back to normal mode and it is also possible to see the visualisation inside the openGL window. But as soon as the openGL windows is klicked again and so comes to foreground, the screen turns to this strange behaviour.

The weird thing is:

Every KDE4 program started after the G4 programm shows the same behaviour, it seems that non-KDE4 applications like Thunderbird, Firefox, Pidgin are not affected. To get rid of the problem, X has so be restarted.

I'm using OpenSuse 11.2 64bit on a system with a radeon graphics card, driver is radeonHD, acceleration is enabled.

I can post further information, but tell me what you need.

Has anybody seen the same behaviour? Or is there a known solution?

Thanks

Sebastian Weber

Inline Depth:
 1 1
 All All
Outline Depth:
 1 1
 2 2
 All All
Add message: (add)

1 None: Re: Whole screen becomes black or false-colored   (Joseph Perl - 07 May, 2010)
(_ None: Re: Whole screen becomes black or false-colored   (sweber - 07 May, 2010)
 Add Message Add Message
to: "Whole screen becomes black or false-colored"

 Subscribe Subscribe

This site runs SLAC HyperNews version 1.11-slac-98, derived from the original HyperNews


[ Geant 4 Home | Geant 4 HyperNews | Search | Request New Forum | Feedback ]