Message: no more OpenGL on my machine Not Logged In (login)
 Next-in-Thread Next-in-Thread
 Next-in-Forum Next-in-Forum

None no more OpenGL on my machine 

Forum: (Graphical) User Interfaces
Date: 23 Dec, 2009
From: sauvestre <sauvestre>

hi, i have a serious problem (not so serious but i don t know how to do !!). I have download the version 4.9.2.p02 of geant4. In the meantime, the administration of our center has changed the Redhat Linus OS. we are now working with the target x86_64-redhat-linux, Thread model: posix gcc version 4.1.2 20080704 (Red Hat 4.1.2-44) Unfortunetly, there is no more OpenGL directory and that is the point. if i make the ./configure -build and ./configure and then source /geant4/geant4.9.3/env.csh it answers u-tango% source ~/geant4/geant4.9.2.p02/env.csh On this machine the G4SYSTEM=Linux-g++ On this machine the G4INSTALL=/cea/home/b2/sauves/geant4/geant4.9.2.p02 On this machine the G4LIB=/cea/home/b2/sauves/geant4/geant4.9.2.p02/lib On this machine the G4LEVELGAMMADATA=/cea/home/b2/sauves/geant4/geant4.9.2.p02/data/PhotonEvaporation2.0 On this machine the G4RADIOACTIVEDATA=/cea/home/b2/sauves/geant4/geant4.9.2.p02/data/RadioactiveDecay3.2 On this machine the G4LEDATA=/cea/home/b2/sauves/geant4/geant4.9.2.p02/data/G4EMLOW6.2 On this machine the G4NEUTRONHPDATA=/cea/home/b2/sauves/geant4/geant4.9.2.p02/data/G4NDL3.13 On this machine the G4ABLADATA=/cea/home/b2/sauves/geant4/geant4.9.2.p02/data/G4ABLA3.0 On this machine the CLHEP_BASE_DIR=/cea/home/b2/sauves/CLHEP On this machine the CLHEP_INCLUDE_DIR=/cea/home/b2/sauves/CLHEP/include On this machine the CLHEP_LIB_DIR=/cea/home/b2/sauves/CLHEP/lib On this machine the CLHEP_LIB=CLHEP On this machine the G4ANALYSIS_USE=1 On this machine the G4UI_USE_TCSH=1 On this machine the G4VIS_BUILD_OPENGLX_DRIVER=1 On this machine the G4VIS_BUILD_RAYTRACERX_DRIVER=1 On this machine the G4VIS_USE_OPENGLX=1 On this machine the G4VIS_USE_RAYTRACERX=1 On this machine the XMFLAGS= On this machine the XMLIBS= On this machine the XMFLAGS= On this machine the XMLIBS= On this machine the XAWFLAGS= On this machine the XAWLIBS= On this machine the G4LIB_BUILD_STATIC=1 On this machine the G4LIB_USE_GRANULAR=1 In your environment you have the G4WORKDIR=/cea/home/b2/sauves/g4work

all seems ok except that when i want to run a program one reads at the beginning:

*************************************************************
 Geant4 version Name: geant4-09-02-patch-02    (28-August-2009)
                      Copyright : Geant4 Collaboration
                      Reference : NIM A 506 (2003), 250-303
                            WWW : http://cern.ch/geant4
*************************************************************

initialisation of the detector primary generator Visualization Manager instantiating... Visualization Manager initialising... Registering graphics systems...

You have successfully registered the following graphics systems.
Current available graphics systems are:
  ASCIITree (ATree)
  DAWNFILE (DAWNFILE)
  G4HepRep (HepRepXML)
  G4HepRepFile (HepRepFile)
  RayTracer (RayTracer)
  VRML1FILE (VRML1FILE)
  VRML2FILE (VRML2FILE)
  RayTracerX (RayTracerX)
  VRML1 (VRML1)
  VRML2 (VRML2)

Registering model factories...

You have successfully registered the following model factories.
Registered model factories:
  generic
  drawByCharge
  drawByParticleID
  drawByOriginVolume
  drawByAttribute

Registered filter factories:
  chargeFilter
  particleFilter
  originVolumeFilter
  attributeFilter

PreInit>

so as you can see i don t have OpenGL just because it can t reach a directory that doesn t exist anylonger. All i can find is /usr/lib64/qt4/include/QtOpenGL or /usr/lib64/qt4/lib64/libQtOpenGL.prl ... and .so and.so.4.2. and .so.4.2.1

what can i do? I will appreciate greatly an answer as a christmas present. Thanks in advance. All the best to the G4 guys and merry christmas !!!

Inline Depth:
 1 1
 All All
Outline Depth:
 1 1
 2 2
 All All
Add message: (add)

1 None: Re: no more OpenGL on my machine   (sauvestre - 24 Dec, 2009)
1 None: Re: no more OpenGL on my machine   (Tobias Kunz - 01 Oct, 2011)
2 None: Re: no more OpenGL on my machine   (Tobias Kunz - 01 Oct, 2011)
 Add Message Add Message
to: "no more OpenGL on my machine"

 Subscribe Subscribe

This site runs SLAC HyperNews version 1.11-slac-98, derived from the original HyperNews


[ Geant 4 Home | Geant 4 HyperNews | Search | Request New Forum | Feedback ]