Message: Re: GUI problem in Geant 4.9.1 on Suse Linux 11.0 Not Logged In (login)
 Next-in-Thread Next-in-Thread
 Next-in-Forum Next-in-Forum

More Re: GUI problem in Geant 4.9.1 on Suse Linux 11.0 

Forum: (Graphical) User Interfaces
Re: Question GUI problem in Geant 4.9.1 on Suse Linux 11.0 (M Tariq Siddique)
Re: None Re: GUI problem in Geant 4.9.1 on Suse Linux 11.0 (John Allison)
Date: 11 Sep, 2008
From: M Tariq Siddique <M Tariq Siddique>

here is the config.sh file (given below) which i use to build the geant4 first time. i have set the 'g4ui_build_xm_session', 'g4ui_use_xm' and 'g4vis_build_openglxm_driver' as 'yes' during building the config.sh file and then build the geant4 code using same config.sh file. is there something additional need to be done to build the GUIXm session.

#!/bin/sh
#
# This file was produced by running the Configure script. It holds all the
# definitions figured out by Configure. Should you modify one of these values,
# do not forget to propagate your changes by running "Configure -der". You may
# instead choose to run each of the .SH files by yourself, or "Configure -S".
#

# Package name      : g4conf
# Source directory  : .
# Configuration time: Thu Oct 18 10:49:10 PKT 2007
# Configured by     : tariq
# Target system     : linux n11pc-205 2.6.18.8-0.5-default #1 smp fri jun 22 12:17:53 utc 2007 i686 i686 i386 gnulinux 

Author='' Date='' Header='' Id='' Locker='' Log='' RCSfile='' Revision='' Source='' State='' c='' cf_by='tariq' cf_time='Thu Oct 18 10:49:10 PKT 2007' contains='grep' d_portable='undef' eunicefix=':' g4_gmake='y' g4_gmake_version='GNU Make 3.81 Copyright (C) 2006 Free Software Foundation, Inc. This is free software; see the source for copying conditions. There is NO warranty; not even for MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE.

This program built for i686-pc-linux-gnu' g4_make='y' g4_make_version='GNU Make 3.81 Copyright (C) 2006 Free Software Foundation, Inc. This is free software; see the source for copying conditions. There is NO warranty; not even for MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE.

This program built for i686-pc-linux-gnu' g4base='' g4bin='' g4clhep_base_dir='/usr/local/geant4/CLHEP' g4clhep_include_dir='/usr/local/geant4/CLHEP/include' g4clhep_lib='CLHEP' g4clhep_lib_dir='/usr/local/geant4/CLHEP/lib' g4compiler='g++' g4conf='/usr/local/geant4/geant4.9.1.p02/.config/bin/Linux-g++' g4data='/usr/local/geant4/data' g4debug='n' g4elasticdata='' g4final_install='/usr/local/geant4/geant4.9.1.p02' g4global='n' g4granular='y' g4include='' g4includes_flag='n' g4install='/usr/local/geant4/geant4.9.1.p02' g4ledata='/usr/local/geant4/data/G4EMLOW5.1' g4levelgammadata='/usr/local/geant4/data/PhotonEvaporation2.0' g4lib='/usr/local/geant4/geant4.9.1.p02/lib' g4lib_build_shared='n' g4lib_build_static='y' g4lib_use_dll='' g4lib_use_dyn='' g4lib_use_granular='y' g4lib_use_shared='n' g4lib_use_static='n' g4make='gmake' g4neutronhpcrosssections='/usr/local/geant4/data/G4NDL3.12' g4osname='Linux' g4radioactivedata='/usr/local/geant4/data/RadioactiveDecay3.2' g4system='Linux-g++' g4tmp='/usr/local/geant4/geant4.9.1.p02/tmp' g4ui_build_gag_session='y' g4ui_build_terminal_session='y' g4ui_build_win32_session='n' g4ui_build_xaw_session='n' g4ui_build_xm_session='y' g4ui_use_gag='y' g4ui_use_tcsh='y' g4ui_use_terminal='y' g4ui_use_win32='n' g4ui_use_xaw='n' g4ui_use_xm='y' g4ui_xawflags='' g4ui_xawhome='' g4ui_xawlibs='' g4vis_build_asciitree_driver='y' g4vis_build_dawn_driver='n' g4vis_build_dawnfile_driver='y' g4vis_build_oiwin32_driver='n' g4vis_build_oix_driver='n' g4vis_build_openglwin32_driver='n' g4vis_build_openglx_driver='y' g4vis_build_openglxm_driver='y' g4vis_build_raytracer_driver='y' g4vis_build_raytracerx_driver='y' g4vis_build_vrml_driver='n' g4vis_build_vrmlfile_driver='y' g4vis_oglhome='' g4vis_oivhome='' g4vis_use_asciitree='y' g4vis_use_dawn='n' g4vis_use_dawnfile='y' g4vis_use_oiwin32='n' g4vis_use_oix='n' g4vis_use_openglwin32='n' g4vis_use_openglx='y' g4vis_use_openglxm='y' g4vis_use_raytracer='y' g4vis_use_raytracerx='y' g4vis_use_vrml='n' g4vis_use_vrmlfile='y' g4vis_xmflags='' g4vis_xmflags='' g4vis_xmhome='' g4vis_xmhome='' g4vis_xmlibs='' g4vis_xmlibs='' g4w_use_g3tog4='n' g4w_use_zlib='n' g4wanalysis_build='' g4wanalysis_build_jas='' g4wanalysis_build_lab='' g4wanalysis_build_lizard='' g4wanalysis_use='n' g4wanalysis_use_jas='' g4wanalysis_use_lab='' g4wanalysis_use_lizard='' g4wlib_build_g3tog4='n' g4wlib_build_zlib='n' g4workdir='/usr/local/geant4/geant4.9.1.p02' hint='recommended' lns='/bin/ln -s' myuname='linux n11pc-205 2.6.18.8-0.5-default #1 smp fri jun 22 12:17:53 utc 2007 i686 i686 i386 gnulinux ' n='-n' osname='linux' osvers='2.6.18.8-0.5-default' package='g4conf' sh='/bin/sh' sharpbang='#!' shsharp='true' spackage='' spitshell='cat' src='.' startsh='#!/bin/sh' CONFIG=true

Inline Depth:
 1 1
 All All
Outline Depth:
 1 1
 2 2
 All All
Add message: (add)

1 None: Re: GUI problem in Geant 4.9.1 on Suse Linux 11.0   (John Allison - 12 Sep, 2008)
(_ More: Re: GUI problem in Geant 4.9.1 on Suse Linux 11.0   (M Tariq Siddique - 14 Sep, 2008)
(_ None: Re: GUI problem in Geant 4.9.1 on Suse Linux 11.0   (John Allison - 15 Sep, 2008)
 Add Message Add Message
to: "Re: GUI problem in Geant 4.9.1 on Suse Linux 11.0"

 Subscribe Subscribe

This site runs SLAC HyperNews version 1.11-slac-98, derived from the original HyperNews


[ Geant 4 Home | Geant 4 HyperNews | Search | Request New Forum | Feedback ]