Message: Re: GUI problem in Geant 4.9.1 on Suse Linux 11.0 Not Logged In (login)
 Next-in-Thread Next-in-Thread
 Next-in-Forum Next-in-Forum

None Re: GUI problem in Geant 4.9.1 on Suse Linux 11.0 

Forum: (Graphical) User Interfaces
Re: Question GUI problem in Geant 4.9.1 on Suse Linux 11.0 (M Tariq Siddique)
Date: 11 Sep, 2008
From: John Allison <John Allison>

As visTutor/gui.mac says, it for "G4UIXm, G4UIWin32 sessions. It has no effect with G4UIterminal." As you can see from exampleN03.cc, a G4UIXm session is started only if G4UI_USE_XM is defined*, in which case it also executes visTutor/gui.mac

1) Before compiling and building exampleN03, did you set your environment as specified in the Installation Guide?

2) Did you reply "yes" to the question posed by Configure when it asked if you wanted an Xm GUI? If not, the problem will be that the G4UIXm session will not have been built, so simply setting G4UI_USE_XM will not work (you may, of course, try). You may have to rebuild Geant4.

* With the standard Geant4 make system, setting an environment variable such as G4UI_USE_XM causes a C-pre-processor flag of the same name to be set. It is the latter that is used in the C++ code, as in exampleN03.cc.

Inline Depth:
 1 1
 All All
Outline Depth:
 1 1
 2 2
 All All
Add message: (add)

1 More: Re: GUI problem in Geant 4.9.1 on Suse Linux 11.0   (M Tariq Siddique - 11 Sep, 2008)
(_ None: Re: GUI problem in Geant 4.9.1 on Suse Linux 11.0   (John Allison - 12 Sep, 2008)
(_ More: Re: GUI problem in Geant 4.9.1 on Suse Linux 11.0   (M Tariq Siddique - 14 Sep, 2008)
(_ None: Re: GUI problem in Geant 4.9.1 on Suse Linux 11.0   (John Allison - 15 Sep, 2008)
 Add Message Add Message
to: "Re: GUI problem in Geant 4.9.1 on Suse Linux 11.0"

 Subscribe Subscribe

This site runs SLAC HyperNews version 1.11-slac-98, derived from the original HyperNews


[ Geant 4 Home | Geant 4 HyperNews | Search | Request New Forum | Feedback ]