Message: Re: This application failed to start because it could not find or load the Qt platform plugin Not Logged In (login)
 Next-in-Thread Next-in-Thread
 Next-in-Forum Next-in-Forum

None Re: This application failed to start because it could not find or load the Qt platform plugin  

Forum: (Graphical) User Interfaces
Re: None This application failed to start because it could not find or load the Qt platform plugin "xcb" in "". (Delaune Olivier)
Re: None Re: This application failed to start because it could not find or load the Qt platform plugin (Danielle Norcini)
Re: Idea Re: This application failed to start because it could not find or load the Qt platform plugin (Garnier Laurent)
Date: 07 Jan, 2017
From: Delaune Olivier <Delaune Olivier>

Hi Laurent, I just recompiled geant4 10.3 and geant4 10.2 to be sure that everything is similar (qt installation and so on) and result is the same: I can run exampleB1 with Geant 4.10.2p2 and not with Geant4 10.3 (error that I gave previously). So something has changed within the Qt directory management in the Geant4 core that creates this issue. I compared libraies linked to executables in both GEANT4 versions. There are several differences:
* GEANT4 10.2 uses libraries in /lib64 while GEANT4 10.3 uses libraires in /usr/lib64
* Qt path are strictly similar
* GEANT4 10.2 uses /usr/lib64/nvidia-current/libGL.so.1 while GEANT4 10.3 uses /usr/lib64/libGL.so.1
* libglapi.so.0, libXdamage.so.1, libXfixes.so.3, libX11-xcb.so.1, libxcb-glx.so.0, libxcb-dri2.so.0, libxcb-dri3.so.0, libxcb-present.so.0, libxcb-sync.so.1, libxshmfence.so.1, libXxf86vm.so.1 and libdrm.so.2 are used in GEANT4 10.3, not in GEANT4 10.2
* libnvidia-tls.so.352.79 and libnvidia-glcore.so.352.79 are used in GEANT4 10.2 and not GEANT4 10.3
All this makes a lot of differences. During the cmake step, I tried to use the same option and to enable most of the features.

Inline Depth:
 1 1
 All All
Outline Depth:
 1 1
 2 2
 All All
Add message: (add)

1 Ok: Re: This application failed to start because it could not find or load the Qt platform plugin   (Delaune Olivier - 20 Jan, 2017)
 Add Message Add Message
to: "Re: This application failed to start because it could not find or load the Qt platform plugin "

 Subscribe Subscribe

This site runs SLAC HyperNews version 1.11-slac-98, derived from the original HyperNews


[ Geant 4 Home | Geant 4 HyperNews | Search | Request New Forum | Feedback ]