Message: Re: Patch 02 requires Qt 4.x but Mac OSX 10.9.5 has Qt 5.4 Not Logged In (login)
 Next-in-Thread Next-in-Thread
 Next-in-Forum Next-in-Forum

None Re: Patch 02 requires Qt 4.x but Mac OSX 10.9.5 has Qt 5.4 

Forum: (Graphical) User Interfaces
Re: None Patch 02 requires Qt 4.x but Mac OSX 10.9.5 has Qt 5.4 (Andrew Hodgdon)
Date: 15 Oct, 2015
From: Andrew Hodgdon <Andrew Hodgdon>

On Thu, 15 Oct 2015 00:50:28 GMT, radsim wrote:
> I am using Mac OS X 10.9.5 with Qt 5.4. The compiler is looking for Qt 4.x. Is there a fix or suggestion? 
> 
> Here&#65533;s the error message:
> 
> CMake Error at /Applications/CMake.app/Contents/share/cmake-3.2/Modules/FindQt4.cmake:1326 (message):
>   Found unsuitable Qt version "" from NOTFOUND, this code requires Qt 4.x
> 
> Andrew D. Hodgdon
> andrew@radsim.org
> www.linkedin.com/in/andrewhodgdon
> 617 835 6755 cell
> 
>  [ MIME part of type text/html without a name stripped ]
> 

With help of Andrea Dotti the following sequence worked:

This is the sequence I used to load GEANT4 10.01.p02 with Qt5.5 to a MAC OS X 10.9.5 ADH 151015

# this assumes G4.tar has been downloaded
# this assumes that Qt5.5 has been downloaded. I downloaded the free version but had to setup an account. http://www.qt.io/download/ 

mkdir G4tut and cd to G4tut

# load geant4 and untar it
# if you have a former build and need to re-build G4 you must delete former build folder which I did in finder by dragging it to trash.
mkdir build cd build

# The cmake command needs the path to Qt/<version>/<compiler> in my case 5.5/clang_64. To do this on my MAC I go to finder, search for Qt, click down to Clang_64 then down to bin, command i opens info, copy path, which in my case is /Users/andrew/Qt/5.5/clang_64. This gets used in the G4 cmake.

cmake -DCMAKE_INSTALL_PREFIX=../ -DGEANT4_BUILD_MULTITHREADED=ON -DGEANT4_INSTALL_DATA=ON -DCMAKE_PREFIX_PATH=/Users/andrew/Qt/5.5/clang_64 -DGEANT4_USE_QT=ON ../geant4.10.01.p02

cd G4tut source bin/geant4.sh mkdir build-exB1 cd build-exB1

# to run example B1

cmake -DGeant4_DIR=../lib/Geant4-10.1.2 ../share/Geant4-10.1.2/examples/basic/B1 make -j2 export G4UI_USE_QT=1 ./exampleB1

# you should see the full GUI

 Add Message Add Message
to: "Re: Patch 02 requires Qt 4.x but Mac OSX 10.9.5 has Qt 5.4"

 Subscribe Subscribe

This site runs SLAC HyperNews version 1.11-slac-98, derived from the original HyperNews


[ Geant 4 Home | Geant 4 HyperNews | Search | Request New Forum | Feedback ]