Message: Run manager error in a new Geant4 version Not Logged In (login)
 Next-in-Thread Next-in-Thread
 Next-in-Forum Next-in-Forum

Question Run manager error in a new Geant4 version 

Keywords: runManager->Initialize()
Forum: Run Management
Date: 22 Oct, 2004
From: Teresa Marrodan Undagoitia <tmarroda@ph.tum.de>

Hi,

Im trying to run a program in a new version of Geant4 and Im having problems.

My program was working properly in Geant4.5.2 in another computer, now Im trying to run the same program in Geant4.6.2. I could manage to make it compile but now when I run the program it crashes just after the line:

 runManager->Initialize();

The message that I get is: Abgebrochen, the german word for Broken. I wanted to ask if someone have some idea about what is happening.

I dont know if it has to do with the problem but maybe. At the beginning I had a compilation error because my program uses a variable that before was public and now is protected. It was:

->GetCrossSectionDataStore();

I as looking at the Geant4 program were it was and I just change it from protected to pulic to be able to compile. I still trying to fin why this has been changed in the new version but I dont find anything. Maybe is this the problem ... ?

Thank you

Teresa

Inline Depth:
 1 1
 All All
Outline Depth:
 1 1
 2 2
 All All
Add message: (add)

1 None: Re: Run manager error in a new Geant4 version   (Makoto Asai - 22 Oct, 2004)
(_ Ok: Problem solved!   (Teresa Marrodan Undagoitia - 26 Oct, 2004)
 Add Message Add Message
to: "Run manager error in a new Geant4 version"

 Subscribe Subscribe

This site runs SLAC HyperNews version 1.11-slac-98, derived from the original HyperNews


[ Geant 4 Home | Geant 4 HyperNews | Search | Request New Forum | Feedback ]