Message: GPS problem with /biasx /biasy Not Logged In (login)
 Next-in-Thread Next-in-Thread
 Next-in-Forum Next-in-Forum

Sad GPS problem with /biasx /biasy 

Forum: Run Management
Date: 28 Sep, 2018
From: filippo <filippo>

Hi,

In my simulation I use GPS as particle source, attached there's my macro where I set biasx and biasy (according to example exGPS/test23.mac). The program works fine but when I use the command EXIT after a completed run I get:

G4Allocator objects are deleted. UImanager deleted. StateManager deleted. RunManagerKernel is deleted. Good bye :)

Program received signal SIGSEGV, Segmentation fault.

Using GDB backtrace I found out that the problem is something related to the ParticleSource (in back_trace.txt attached there is the full output ). I've finally found out that if I remove the biasx and y histograms the program terminates without any error! I'm using the latest version of Geant4 without MT enabled.

Is this a known issue or there's something wrong with my simulation?

Thank you an best regards

Filippo

   Attachment:
      http://hypernews.slac.stanford.edu/HyperNews/geant4/get/AUX/2018/09/28/14.27-54340-back_trace.txt
      http://hypernews.slac.stanford.edu/HyperNews/geant4/get/AUX/2018/09/28/14.27-73898-gps.mac

Inline Depth:
 1 1
 All All
Outline Depth:
 1 1
 2 2
 All All
Add message: (add)

1 Sad: Re: GPS problem with /biasx /biasy   (filippo - 29 Sep, 2018)
 Add Message Add Message
to: "GPS problem with /biasx /biasy"

 Subscribe Subscribe

This site runs SLAC HyperNews version 1.11-slac-98, derived from the original HyperNews


[ Geant 4 Home | Geant 4 HyperNews | Search | Request New Forum | Feedback ]