Message: Re: About /random/setSeeds Not Logged In (login)
 Next-in-Thread Next-in-Thread
 Next-in-Forum Next-in-Forum

Idea Re: About /random/setSeeds 

Forum: Run Management
Re: Question About /random/setSeeds (Ibrahim)
Date: 16 Mar, 2018
From: Stefan E. Mueller <Stefan E. Mueller>

Dear Ibrahim,

which version of Geant4 are you using? There was indeed a bug in the 
/random/setSeeds
command some time ago
(see 
http://hypernews.slac.stanford.edu/HyperNews/geant4/get/runmanage/371.html
), however this only occured when using a version of Geant4 which was compiled with multithreading possibilities enabled.

But this should be fixed by now.

Stefan

On Mon, 20 Nov 2017 12:38:24 GMT, Ibrahim wrote:
> Dear all,
> 
> I want to run the same simulation many times and getting each time
> different results. To do so I just issue the following command in my
> macro files (run0x.mac):
> 
> ---run01.mac:
> 
> ...
> 
> /run/initialize
> 
> /random/setSeeds 575841912 838392977
> 
> /run/beamOn 2000000
> 
> ...
> 
> ----run02.mac
> 
> ...
> 
> /run/initialize
> 
> /random/setSeeds 575841915 838392979
> 
> /run/beamOn 2000000
> 
> ...
> 
> but when I score the number of particles reaching the detector, the
> results are always the same. That means /random/setSeeds is not
> working!. What is wrong? thanks in advance ...
> 
> Cheers
> 
> A.H.
> 

 Add Message Add Message
to: "Re: About /random/setSeeds"

 Subscribe Subscribe

This site runs SLAC HyperNews version 1.11-slac-98, derived from the original HyperNews


[ Geant 4 Home | Geant 4 HyperNews | Search | Request New Forum | Feedback ]