Message: Re: Inserting the DetectorMessenger Class Not Logged In (login)
 Next-in-Thread Next-in-Thread
 Next-in-Forum Next-in-Forum

None Re: Inserting the DetectorMessenger Class 

Forum: Run Management
Re: None Inserting the DetectorMessenger Class (G.A.P.Cirrone)
Date: 07 Apr, 2004
From: Vladimir Ivanchenko <Vladimir Ivanchenko>

On Wed, 7 Apr 2004, Pablo Cirrone wrote:

> *** Discussion title: Run Management
> Email replies to PublicHyperNews@slac.stanford.edu must include:
>   In-Reply-To: <"/runmanage/42"@geant4-hn.slac.stanford.edu>
>   Subject: ...change this to be about your reply.
> 
> Hello, I have a very stupid problem.... Starting from
> examples/novice/N01 (where no messengers are defined) and after a
> modification of its geometry I tried to insert a detector messenger
> class to control the thickness of an element. I simply copied the
> messenger files from N03 example, modifing the opportunely.
> 
> :ExN03Detector(ExN03Det)
> { 
>   N03Dir = new G4UIdirectory("/N03/");
>   N03Dir->SetGuidance("UI commands of this example");
> 
> detDir = new G4UIdirectory("/N03/det/"); ..................
> 
> In this way the new command
> 
> /N03/det
>  should be created.
> 
> When I compile my files all is ok, but when I run the program in the
> list of the IDLE commands the command /N03/det doesn't appear.
> 
> Someone know where could be the problem?
> 
> thank you
> 

Hi Pablo,

First of all check the state for which the command is applicable. You may 
be need PreInit or PreRun, or Idle.

VI


Inline Depth:
 1 1
 All All
Outline Depth:
 1 1
 2 2
 All All
Add message: (add)

1 Ok: Re: Inserting the DetectorMessenger Class   (Pablo - 08 Apr, 2004)
 Add Message Add Message
to: "Re: Inserting the DetectorMessenger Class"

 Subscribe Subscribe

This site runs SLAC HyperNews version 1.11-slac-98, derived from the original HyperNews


[ Geant 4 Home | Geant 4 HyperNews | Search | Request New Forum | Feedback ]