Message: Re: Problem with CLHEP RandGeneral Not Logged In (login)
 Next-in-Thread Next-in-Thread
 Next-in-Forum Next-in-Forum

Feedback Re: Problem with CLHEP RandGeneral 

Forum: Run Management
Re: Question Problem with CLHEP RandGeneral (valentina)
Date: 16 Jan, 2009
From: Gumplinger Peter <Gumplinger Peter>

Hello Valentina,

My guess is that there is something wrong with the probability distribution you hand to RandGeneral. I googled and found some explanation about the method at:

http://wwwasd.web.cern.ch/wwwasd/lhc++/clhep/manual/RefGuide/Random/RandGeneral.html

e.g. The probability distribution function (Pdf) must be provided by the user as an array of positive real number.

Also, the reason you can't reproduce the problem with your seed may have to do with this comment:

"In case no engine is specified in the constructor, the default engine used by the static generator is applied. If the engine is passed by reference the corresponding engine object will not be deleted by the RandGeneral destructor."

Looks like RandGeneral and Geant4 don't use the same engine.

My two cents, Peter

Inline Depth:
 1 1
 All All
Outline Depth:
 1 1
 2 2
 All All
Add message: (add)

1 Ok: Re: Problem with CLHEP RandGeneral   (valentina - 20 Jan, 2009)
(_ Feedback: Re: Problem with CLHEP RandGeneral   (Giovanni Santin - 12 Feb, 2009)
 Add Message Add Message
to: "Re: Problem with CLHEP RandGeneral"

 Subscribe Subscribe

This site runs SLAC HyperNews version 1.11-slac-98, derived from the original HyperNews


[ Geant 4 Home | Geant 4 HyperNews | Search | Request New Forum | Feedback ]