Message: Re: G4RandGauss Not Logged In (login)
 Next-in-Thread Next-in-Thread
 Next-in-Forum Next-in-Forum

Sad Re: G4RandGauss 

Forum: Run Management
Re: None G4RandGauss (Jerome Roccaz)
Date: 14 Feb, 2003
From: Jerome Roccaz <roccaz@csnsm.in2p3.fr>

to be more explicit, here is a part of my code :

RandEngine theEngine;
  HepRandom::setTheEngine(&theEngine);
  HepRandomEngine* engine=HepRandom::getTheEngine();
  De=G4RandGauss(engine, 0., 1.)->shoot();

When I compile, i obtain this error message :

Making dependency for file src/SimpleGeHit.cc ... Compiling SimpleGeHit.cc ... "src/SimpleGeHit.cc", line 27: Error: Pointer type needed instead of RandGaussQ. 1 Error(s) detected.

gmake: *** [../geant4.4.0/tmp/SUN-CC/SimpleGe/SimpleGeHit.o] Error 1

Inline Depth:
 1 1
 All All
Outline Depth:
 1 1
 2 2
 All All
Add message: (add)

1 None: Re: G4RandGauss   (michel maire - 14 Feb, 2003)
(_ Ok: Re: G4RandGauss   (Jerome Roccaz - 14 Feb, 2003)
 Add Message Add Message
to: "Re: G4RandGauss"

 Subscribe Subscribe

This site runs SLAC HyperNews version 1.11-slac-98, derived from the original HyperNews


[ Geant 4 Home | Geant 4 HyperNews | Search | Request New Forum | Feedback ]