Message: Problem adding physics list Not Logged In (login)
 Next-in-Thread Next-in-Thread
 Next-in-Forum Next-in-Forum

Question Problem adding physics list 

Forum: Physics List
Date: 15 Oct, 2011
From: bilal <bilal>

Hi everyone, I know this problem has been posted before but i couldn't find the solution. I copied all the physics list and messenger class from TestEm5 into my code and compiled it, which was fine. However when i run the following macro it produces an error saying "illegal application state <../../addPhysics local>. The macro is the following. I tried adding /run/initialize before the addPhysics line as well still not working.

/control/verbose 2

/run/verbose 2

/testem/phys/addPhysics local

/testem/phys/setGCut 0.5 um

/testem/phys/setECut 1 mm

/testem/phys/setPCut 1 mm

/run/initialize

# ----------------
# Verbose settings
# ----------------
/gps/verbose 0 #/gps/ion 2 4 +2 0 /gps/particle proton

/gps/pos/type Volume

/gps/pos/shape Cylinder

/gps/pos/centre 0 0 -4. cm

#/gps/pos/halfx 1.5 cm
#/gps/pos/halfy 1.5 cm

/gps/pos/radius 1.5 cm

/gps/pos/halfz 0.5 cm

/gps/direction 0 0 1

/gps/energy 3.5 MeV

/run/beamOn 1000000

Inline Depth:
 1 1
 All All
Outline Depth:
 1 1
 2 2
 All All
Add message: (add)

1 Note: Re: Problem adding physics list   (bilal - 15 Oct, 2011)
(_ None: Re: Problem adding physics list   (Neoh - 15 Oct, 2011)
(_ More: Re: Problem adding physics list   (bilal - 16 Oct, 2011)
(_ None: Re: Problem adding physics list   (Neoh - 16 Oct, 2011)
 Add Message Add Message
to: "Problem adding physics list"

 Subscribe Subscribe

This site runs SLAC HyperNews version 1.11-slac-98, derived from the original HyperNews


[ Geant 4 Home | Geant 4 HyperNews | Search | Request New Forum | Feedback ]