Message: Re: G4NuclearLevelManager Not Logged In (login)
 Next-in-Thread Next-in-Thread
 Next-in-Forum Next-in-Forum

None Re: G4NuclearLevelManager 

Forum: Physics List
Re: None G4NuclearLevelManager
Date: 02 Mar, 2006
From: Hisashi Kitamura <Hisashi Kitamura>

User wrote:

>> Hello,
>> 
>> I changed to Geant4.8.0.p01 and get now the following messages during my
>> runs:
>> 
>> G4NuclearLevelManager: nuclide (28,57) does not have a gamma levels file
>> 
>> G4NuclearLevelManager: nuclide (6,14) does not have a gamma levels file
>> 
>> G4NuclearLevelManager: nuclide (25,53) does not have a gamma levels file
>> 
>> G4NuclearLevelManager: nuclide (28,59) does not have a gamma levels file
>> 
>> G4NuclearLevelManager: nuclide (23,47) does not have a gamma levels file
>> 
>> Does anybody know what that could mean? Do I miss any gamma level files?
>> 
>> Best regards, Markus

Hello,

This messages are generated at G4NuclearLevelManager::MakeLevels().

> void G4NuclearLevelManager::MakeLevels()
> {
>   _validity = false;
>   std::ifstream inFile(_fileName, std::ios::in);
>   if (! inFile)
>     {
>       G4cout << " G4NuclearLevelManager: nuclide (" << _nucleusZ << "," << _nucleusA
>              << ") does not have a gamma levels file" << G4endl;
>       return;
>     }

The error messages are diaplayed for geant4.8.0.p01, but these lines are comment-outed for older version.

I recommend you check whether your "G4LEVELGAMMADATA" valiable is correct or not.

Inline Depth:
 1 1
 All All
Outline Depth:
 1 1
 2 2
 All All
Add message: (add)

1 None: Re: G4NuclearLevelManager   (Markus.Stockner@cern.ch - 02 Mar, 2006)
3 None: Re: G4NuclearLevelManager   (Sara Vecchio - 30 Mar, 2006)
 Add Message Add Message
to: "Re: G4NuclearLevelManager"

 Subscribe Subscribe

This site runs SLAC HyperNews version 1.11-slac-98, derived from the original HyperNews


[ Geant 4 Home | Geant 4 HyperNews | Search | Request New Forum | Feedback ]