Message: Random engine in multithreaded Geant4 Not Logged In (login)
 Next-in-Thread Next-in-Thread
 Next-in-Forum Next-in-Forum

Question Random engine in multithreaded Geant4 

Forum: Particles
Date: 22 Aug, 2014
From: Armin Schuebel <Armin Schuebel>

Hi,

I have a problem with the Random engine in multithreaded Geant4. I want to do imaging with my project and so far everything works fine. I start the simulation in various runs with multiple threads per run. The results are then combined afterwards. Therefore I need different seeds. However, I see that the resulting image appears to be the same between the different simulations even though the initial particles are different.

The random engine is the default engine and the seed is set using:

G4int seed = time( NULL ); G4Random::setTheSeed( seed );

System is Ubuntu 13.10 Geant4.10 patch 1

I usually simulate 60 million particles per run.

Thanks for any ideas to solve that problem.

Armin

Inline Depth:
 1 1
 All All
Outline Depth:
 1 1
 2 2
 All All
Add message: (add)

1 Idea: Re: Random engine in multithreaded Geant4   (David - 22 Aug, 2014)
(_ None: Re: Random engine in multithreaded Geant4   (Armin Schuebel - 23 Aug, 2014)
(_ Question: Re: Random engine in multithreaded Geant4   (Armin Schuebel - 27 Aug, 2014)
(_ None: Re: Random engine in multithreaded Geant4   (Arlychev Mikhail - 18 Sep, 2014)
 Add Message Add Message
to: "Random engine in multithreaded Geant4"

 Subscribe Subscribe

This site runs SLAC HyperNews version 1.11-slac-98, derived from the original HyperNews


[ Geant 4 Home | Geant 4 HyperNews | Search | Request New Forum | Feedback ]