Message: Storing initial kinetic energies of decay products Not Logged In (login)
 Next-in-Thread Next-in-Thread
 Next-in-Forum Next-in-Forum

Question Storing initial kinetic energies of decay products 

Forum: Particles
Date: 13 May, 2013
From: Daryn Cressy <Daryn Cressy>

Hi there,

I am currently working on an analysis project which involves comparing the initial energies of several isotope's decay products from 3 event generators (1 of which is geant).

Note: I am with the SNO+ collaboration, and we use a program called RAT to run our simulations (which uses the geant code).

For all 3 generators, I use a macro to simulate the decay inside our detector (0 MeV point source; 100,000 events per simulation), and use ROOT to display the results (i.e. the GetKE histogram shows the initial kinetic energies of all decay products).

However, when I look at the GetKE graph from the geant simulation, the kinetic energies are not shown. Instead, I get a single peak at 0 MeV for 100,000 events.

I was told there is a problem with storing this info inside the geant code, but I'm not sure where the problem is or how to fix it.

I have attached a sample macro.

Any thoughts?

   Attachment:
      http://hypernews.slac.stanford.edu/HyperNews/geant4/get/AUX/2013/05/13/10.57-79472-Bi214_geant_macro.docx

Inline Depth:
 1 1
 All All
Outline Depth:
 1 1
 2 2
 All All
Add message: (add)

1 Feedback: Re: Storing initial kinetic energies of decay products   (Gumplinger Peter - 13 May, 2013)
 Add Message Add Message
to: "Storing initial kinetic energies of decay products"

 Subscribe Subscribe

This site runs SLAC HyperNews version 1.11-slac-98, derived from the original HyperNews


[ Geant 4 Home | Geant 4 HyperNews | Search | Request New Forum | Feedback ]