Message: I tried to solve the same problem Not Logged In (login)
 Next-in-Thread Next-in-Thread
 Next-in-Forum Next-in-Forum

More I tried to solve the same problem 

Forum: Particles
Re: Question GPS negative z-direction (matthew)
Date: 03 Nov, 2011
From: Ivan Sivacek <Ivan Sivacek>

I have exactly the same problem. I am shooting heavy ions into my detector setup. While it was just one ray, there were no problems, everything went fine:

/gps/ion 88 218 1 0

/gps/energy 40. keV

/gps/position 0.625 0. 80. mm

/gps/direction 0. 0. 1.

/gps/pos/type Beam

(beam have to travel along +z axis)

When I added beam2d spreading, beam started to travel along -z axis and there was nothing I could do with it.

#/gps/pos/centre 0.625 0. 80. mm
#/gps/pos/halfx 0.1 mm
#/gps/pos/halfy 1. mm
#/gps/ang/type beam2d
#/gps/pos/sigma_x 0.011 rad
#/gps/pos/sigma_y 0.046 rad

I tried to rotate beam and source shape, but it newer shoot particles along +z axis.

#/gps/pos/rot1 
#/gps/pos/rot2
#/gps/ang/rot1
#/gps/ang/rot2
(I tried all combinations, but without effect. And in some cases the beam disappeared...)

Can somebody help us how to point our beams along +z axis ? Or there is a bug ?

Thank You.

Inline Depth:
 1 1
 All All
Outline Depth:
 1 1
 2 2
 All All
Add message: (add)

1 Question: problem is still here. can anybody help, please ?   (Ivan Sivacek - 22 Nov, 2011)
(_ Feedback: Re: problem is still here. can anybody help, please ?   (Gumplinger Peter - 22 Nov, 2011)
 Add Message Add Message
to: "I tried to solve the same problem"

 Subscribe Subscribe

This site runs SLAC HyperNews version 1.11-slac-98, derived from the original HyperNews


[ Geant 4 Home | Geant 4 HyperNews | Search | Request New Forum | Feedback ]