Message: Re: Creating an Isotope and applying it to the particle gun Not Logged In (login)
 Next-in-Thread Next-in-Thread
 Next-in-Forum Next-in-Forum

None Re: Creating an Isotope and applying it to the particle gun 

Forum: Particles
Re: None Creating an Isotope and applying it to the particle gun (Matthew Gignac)
Re: None Re: Creating an Isotope and applying it to the particle gun (Michael H. Kelsey)
Re: None Re: Creating an Isotope and applying it to the particle gun (Matthew Gignac)
Re: None Re: Creating an Isotope and applying it to the particle gun (michel maire)
Re: None Re: Creating an Isotope and applying it to the particle gun (Matthew Gignac)
Date: 14 Nov, 2010
From: michel maire <michel maire>

On Sat, 13 Nov 2010 23:55:45 GMT, Matthew Gignac wrote:

> 
> *** G4Exception : Illegal operation
>       issued by : G4IonTable::CreateIon()
> Can not create ions in PreInit state
> *** This is just a warning message.
> 
> *** G4Exception : Event00003
>       issued by : G4ParticleGun::SetParticleDefinition()
> Null pointer is given.
> *** Fatal Exception *** core dump ***
> 
> *** G4Exception: Aborting execution ***
> Abort trap"
> 
> I am not sure what is going wrong? Any clue?

 Did you built Ions in your PhysicsList::ConstructParticle() ?

   // ions
  G4IonConstructor iConstructor;
  iConstructor.ConstructParticle();  

    Cheers, Michel

Inline Depth:
 1 1
 All All
Outline Depth:
 1 1
 2 2
 All All
Add message: (add)

1 Idea: Re: Creating an Isotope and applying it to the particle gun   (Vladimir Ivanchenko - 14 Nov, 2010)
(_ None: Re: Creating an Isotope and applying it to the particle gun   (Matthew Gignac - 15 Nov, 2010)
(_ Ok: Re: Creating an Isotope and applying it to the particle gun   (Matthew Gignac - 15 Nov, 2010)
 Add Message Add Message
to: "Re: Creating an Isotope and applying it to the particle gun"

 Subscribe Subscribe

This site runs SLAC HyperNews version 1.11-slac-98, derived from the original HyperNews


[ Geant 4 Home | Geant 4 HyperNews | Search | Request New Forum | Feedback ]