Message: Re: Too many particles causing Segmentation Error Not Logged In (login)
 Next-in-Thread Next-in-Thread
 Next-in-Forum Next-in-Forum

None Re: Too many particles causing Segmentation Error 

Forum: Particles
Re: Question Too many particles causing Segmentation Error (Daniel O'Brien)
Re: Note Re: Too many particles causing Segmentation Error (Juan)
Re: None Re: Too many particles causing Segmentation Error (Paul Nicholas Colin Gloster)
Date: 19 Mar, 2009
From: Daniel O'Brien <Daniel O'Brien>

Thank you both very much for your reply and for taking the time to investigate this. I really appreciate it. That makes total sense, I didn't realise that the shell limited the memory usage of the program! I've done what both of you have suggested and it works perfectly. It works as is if I increase the stack size and it works anyway if I use runManager->BeamOn(300000).

However, would I be correct in thinking that using runManager->BeamOn(300000) would mean that it would be impossible for each primary particle or any of its secondary particles to have interactions with any other primary or secondary particle, as they would all be calculated separately? Or is that always the case?

Daniel

Inline Depth:
 1 1
 All All
Outline Depth:
 1 1
 2 2
 All All
Add message: (add)

1 Feedback: Re: Too many particles causing Segmentation Error   (Gumplinger Peter - 19 Mar, 2009)
(_ Agree: Re: Too many particles causing Segmentation Error   (Daniel O'Brien - 20 Mar, 2009)
 Add Message Add Message
to: "Re: Too many particles causing Segmentation Error"

 Subscribe Subscribe

This site runs SLAC HyperNews version 1.11-slac-98, derived from the original HyperNews


[ Geant 4 Home | Geant 4 HyperNews | Search | Request New Forum | Feedback ]