Message: Problem in defining source using gps Not Logged In (login)
 Next-in-Thread Next-in-Thread
 Next-in-Forum Next-in-Forum

Question Problem in defining source using gps 

Forum: Particles
Date: 10 Dec, 2008
From: Anil <Anil>

Using thread#91, I have included Radioactive decay in PhysicsList. Iam using following gps commands to simulate radioactive decay of Cs-137. The energy deposited by each gamma ray in NaI crystal is stored in an output ASCII file. But the energy deposited is zero for all particles. Where is the mistake?

/gps/particle ion

/gps/ion 55 137 0 0

/gps/energy 0. keV

/gps/pos/type Point

/gps/pos/centre 0. 0. 0. mm

/gps/ang/type iso

/gps/number 1

/control/verbose 2

/run/verbose 2

/run/beamOn 1000

Also, for following gps commands, the trajectories are not appearing in HepRepFile. Where is the mistake?

/gps/particle ion

/gps/ion 55 137 0 0

/gps/energy 0. keV

/gps/pos/type Point

/gps/pos/centre 0. 0. 0. mm

/gps/ang/type iso

/gps/number 100

/vis/open HepRepFile

/vis/drawVolume

/vis/scene/add/trajectories

/vis/scene/add/hits

/run/beamOn 1

Please help me. I am confused.

Thanks in advance!

Inline Depth:
 1 1
 All All
Outline Depth:
 1 1
 2 2
 All All
Add message: (add)

1 None: Re: Problem in defining source using gps   (Oscar García - 10 Jan, 2011)
 Add Message Add Message
to: "Problem in defining source using gps"

 Subscribe Subscribe

This site runs SLAC HyperNews version 1.11-slac-98, derived from the original HyperNews


[ Geant 4 Home | Geant 4 HyperNews | Search | Request New Forum | Feedback ]