Message: RE: Generating 2 particles with different energies Not Logged In (login)
 Next-in-Thread Next-in-Thread
 Next-in-Forum Next-in-Forum

None RE: Generating 2 particles with different energies 

Forum: Particles
Re: None Generating 2 particles with different energies (Adam)
Re: None RE: Generating 2 particles with different energies (Makoto Asai)
Re: None RE: Generating 2 particles with different energies (Adam)
Re: None RE: Generating 2 particles with different energies (Makoto Asai)
Date: 11 Jun, 2007
From: Adam <ax_blais@laurentian.ca>

Thank you for your help. It turns out the segmentation fault was due to the wrong units being used. In essence, I was shooting 2.4578GeV electrons and they were escaping the world volume.

I do have one more question:

I am getting 2 outputs like this before every event:

G4ParticleGun::e-
  KineticEnergy and Momentum could be inconsistent
 (Momentum:0.001 GeV/c  Mass:0.00051 GeV/c/c)
  KineticEnergy is overwritten!! 0.0014->0.00061GeV

What is the reason for this?

Inline Depth:
 1 1
 All All
Outline Depth:
 1 1
 2 2
 All All
Add message: (add)

1 None: RE: Generating 2 particles with different energies   (Makoto Asai - 11 Jun, 2007)
(_ None: RE: Generating 2 particles with different energies   (Adam - 11 Jun, 2007)
 Add Message Add Message
to: "RE: Generating 2 particles with different energies"

 Subscribe Subscribe

This site runs SLAC HyperNews version 1.11-slac-98, derived from the original HyperNews


[ Geant 4 Home | Geant 4 HyperNews | Search | Request New Forum | Feedback ]