Message: GetParticleCode: unsupported particle Error Not Logged In (login)
 Next-in-Thread Next-in-Thread
 Next-in-Forum Next-in-Forum

Question GetParticleCode: unsupported particle Error 

Keywords: GetParticleCode: unsupported particle Error
Forum: Particles
Date: 21 Apr, 2006
From: Rick Foster <rickf@space.mit.edu>

I am running a simulation the uses the Wilson Abrasion Model, along with standard ionization processes.

The primary particle is 1 GeV/nuc Fe56.

It seems to run fine, but after some number of events, it crashes with the following error:

*********************************************************************************************************
* G4Track Information:   Particle = Ar41[0.0],   Track ID = 69,   Parent ID = 1
*********************************************************************************************************

Step#      X         Y         Z        KineE    dEStep   StepLeng  TrakLeng    Volume     Process
    0   89.8 mum  2.56 mm  -4.58 cm   41.2 GeV     0 eV      0 fm      0 fm         TEP1    initStep

*** G4Exception : 007
      issued by : G4HadronCrossSections
GetParticleCode: unsupported particle
*** Fatal Exception *** core dump ***

*** G4Exception: Aborting execution ***

Any ideas would be appreciated.

Thanks Rick

PS: I did look at thread 87, but they didn't post a conclusion.

Inline Depth:
 1 1
 All All
Outline Depth:
 1 1
 2 2
 All All
Add message: (add)

1 Idea: Re: GetParticleCode: unsupported particle Error - Fixed (??)   (Rick Foster - 27 Apr, 2006)
 Add Message Add Message
to: "GetParticleCode: unsupported particle Error"

 Subscribe Subscribe

This site runs SLAC HyperNews version 1.11-slac-98, derived from the original HyperNews


[ Geant 4 Home | Geant 4 HyperNews | Search | Request New Forum | Feedback ]