Message: Re: Bad response using G4PrimaryParticle GetCharge() method. Not Logged In (login)
 Next-in-Thread Next-in-Thread
 Next-in-Forum Next-in-Forum

More Re: Bad response using G4PrimaryParticle GetCharge() method. 

Forum: Particles
Re: Warning Bad response using G4PrimaryParticle GetCharge() method. (Paulo Mora de Freitas)
Re: None Re: Bad response using G4PrimaryParticle GetCharge() method. (Vladimir Ivanchenko)
Re: More Re: Bad response using G4PrimaryParticle GetCharge() method. (Gumplinger Peter)
Re: Ok Re: Bad response using G4PrimaryParticle GetCharge() method. (Paulo Mora de Freitas)
Date: 02 Aug, 2002
From: Gumplinger Peter <Gumplinger Peter>

Dear Paulo,

What's the situation with the data member 'mass' of G4PrimaryParticle? Can you tell me whether the method G4PrimaryParticle::GetMass (or SetMass) is used anywhere in the G4 code? It's difficult to tell because the method name appears also in other classes. Since it is redundant, and it is still identical to zero in G4PrimaryParticle, even after the latest patch, why is it in the class at all? At some point in the future, another user will be wondering, why he/she gets zero mass for the G4PrimaryParticle.

At a minimum, the mass should be initialized the same way as you now initialize the charge.

Peter

Inline Depth:
 1 1
 All All
Outline Depth:
 1 1
 2 2
 All All
Add message: (add)

 Add Message Add Message
to: "Re: Bad response using G4PrimaryParticle GetCharge() method."

 Subscribe Subscribe

This site runs SLAC HyperNews version 1.11-slac-98, derived from the original HyperNews


[ Geant 4 Home | Geant 4 HyperNews | Search | Request New Forum | Feedback ]