Message: Problem with Cerenkov Process and EM Option 4 (or 3...) Not Logged In (login)
 Next-in-Thread Next-in-Thread
 Next-in-Forum Next-in-Forum

Warning Problem with Cerenkov Process and EM Option 4 (or 3...) 

Forum: Processes Involving Optical Photons
Date: Mar 01, 17:36
From: Nicole Ackerman <Nicole Ackerman>

I've been investigating some inconsistencies in my simulation results and I think I have found a "bug". I have been able to reproduce it in the OpNovice2 example with the following:

In electron.mac, I made the following changed:
/opnovice2/boxMaterial G4_WATER
/opnovice2/worldMaterial G4_AIR
/opnovice2/boxProperty RINDEX .000002 1.33 .000008 1.33
/gun/energy 265 keV
(all others are left as they are)

The type of output that I see:
G4WT1 > Step# X(mm) Y(mm) Z(mm) KinE(MeV) dE(MeV) StepLeng TrackLeng NextVolume ProcName
(snip)
G4WT1 > 80945 -1e+03 0.000154 -0.000117 0.264 2.73e-17 1.11e-16 0.00384 Tank Cerenkov
G4WT1 > 80946 -1e+03 0.000154 -0.000117 0.264 2.73e-17 1.11e-16 0.00384 Tank Cerenkov
G4WT1 > 80947 -1e+03 0.000154 -0.000117 0.264 2.73e-17 1.11e-16 0.00384 Tank Cerenkov
G4WT1 > 80948 -1e+03 0.000154 -0.000117 0.264 2.73e-17 1.11e-16 0.00384 Tank Cerenkov
G4WT1 > 80949 -1e+03 0.000154 -0.000117 0.264 2.73e-17 1.11e-16 0.00384 Tank Cerenkov
G4WT1 > 80950 -1e+03 0.000154 -0.000117 0.264 2.73e-17 1.11e-16 0.00384 Tank Cerenkov
G4WT1 > 80951 -1e+03 0.000154 -0.000117 0.264 2.73e-17 1.11e-16 0.00384 Tank Cerenkov
G4WT1 > 80952 -1e+03 0.000154 -0.000117 0.264 2.73e-17 1.11e-16 0.00384 Tank Cerenkov
G4WT1 > 80953 -1e+03 0.000154 -0.000117 0.264 2.73e-17 1.11e-16 0.00384 Tank Cerenkov
G4WT1 > 80954 -1e+03 0.000154 -0.000117 0.264 2.73e-17 1.11e-16 0.00384 Tank Cerenkov


And I need to just kill the process, because it will keep generating Cerenkov photons.

Specifically, this behavior occurs for charged particles that are very close to the Cerenkov production threshold. I haven't determined the "cause" of the problem beyond that. It doesn't seem to depend on the particle being close to a boundary.

I don't think that I have specified anything "unphysical" in the above changes to the macro file. I first ran into this problem with certain radioactive decays in my own code.

I tested this with a few different EM models. My tests showed it did happen with option3, option4, and Livermore. It did not happen with EMStandard, Penelope, option1, or option2.

Have I stumbled upon a known problem, have I made a mistake, or is this a new bug? Obviously I can just use a different EM physics list. However, my current Cerenkov simulations are not agreeing with simulations I ran a few years ago (and data others have published). The only explanation I have right now is that either something substantial changed in the relevant physics models/processes since 9.6/9.4 or that I currently have a problem with how I have implemented the physics models.

Inline Depth:
 1 1
 All All
Outline Depth:
 1 1
 2 2
 All All
Add message: (add)

1 More: Re: Problem with Cerenkov Process and EM Option 4 (or 3...)   (Nicole Ackerman - Mar 01, 17:49)
2 None: Re: Problem with Cerenkov Process and EM Option 4 (or 3...)   (Daren Sawkey - Mar 04, 09:08)
 Add Message Add Message
to: "Problem with Cerenkov Process and EM Option 4 (or 3...)"

 Subscribe Subscribe

This site runs SLAC HyperNews version 1.11-slac-98, derived from the original HyperNews