Message: Re: G4Exception-START: ELECTRONSCINTILLATIONYIELD Not Logged In (login)
 Next-in-Thread Next-in-Thread
 Next-in-Forum Next-in-Forum

Question Re: G4Exception-START: ELECTRONSCINTILLATIONYIELD 

Forum: Processes Involving Optical Photons
Re: Question G4Exception-START: ELECTRONSCINTILLATIONYIELD (Sergio Lo Meo)
Re: Feedback Re: G4Exception-START: ELECTRONSCINTILLATIONYIELD (Gumplinger Peter)
Date: 12 May, 2016
From: Sergio Lo Meo <Sergio Lo Meo>

Dear Peter,

yesterday, after my first post, I solved the problem, putting in my /src and /include directorys these files: G4OpticalPhysics G4OpticlaPhysicsMessenger G4Scintillation

In OpticalPhysics.cc I set 
 fScintillationByParticleType(true)

But now I have some doubts about my preliminary test results.

In my DetectorConstruction I set:

 G4double SCY_Energy[nentries] = {1.0*MeV, 20.0*MeV, 40.0*MeV, 60.0*MeV, 80.0*MeV, 100.0*MeV, 120.0*MeV, 140.0*MeV,
				  160.0*MeV,180.0*MeV,200.0*MeV,300.0*MeV,400.0*MeV, 500.0*MeV, 600.0*MeV,
				  700.0*MeV, 800.0*MeV, 900.0*MeV, 1000.0*MeV};

G4double SCYELECTRON[nentries]={500.0/MeV, 1750./MeV,3000./MeV,4200./MeV,6000./MeV, 7200./MeV, 9000./MeV, 10000./MeV,
				10000./MeV, 10000./MeV,10000.0/MeV, 10000./MeV, 10000./MeV, 10000./MeV,10000.0/MeV,
				10000./MeV, 10000./MeV, 10000./MeV,10000.0/MeV};

G4double SCYPROTON[nentries]={400.0/MeV, 1000./MeV,2000./MeV,3700./MeV,4500./MeV, 6000./MeV, 7500./MeV, 9000./MeV,
				10000./MeV, 10000./MeV,10000.0/MeV, 10000./MeV, 10000./MeV, 10000./MeV,10000.0/MeV,
				10000./MeV, 10000./MeV, 10000./MeV,10000.0/MeV};

...........

The ScintillationYield of my Scintillator is 10000./MeV optical photons. Now I make two different tests, with the same macro (500 MeV proton) and the same initial seed.

First Test) Only SCINTILLATIONYIELD = 10000./MeV and fScintillationByParticleType(false) In my PMT (QE = 100%) I counted 5967 optical photons ( 1.81 MeV deposited in my Scint)

Second Test) SCY_Energy, SCYELECTRON, SCIPROTON.. fScintillationByParticleType(true) In my PMT (QE = 100%) I counted 83 optical photons ( 1.71 MeV deposited in my Scint)

There is a problem... I think..

If I set 10000./MeV for a 500 MeV proton, I supposed to see few thousand of op. photons (for 1.7 MeV energy deposition) as in my first test and not few dozen (in my second test)...

Where is my mistake?

Thanks in advance. Best Regards.

Sergio Lo Meo

Inline Depth:
 1 1
 All All
Outline Depth:
 1 1
 2 2
 All All
Add message: (add)

1 Feedback: Re: G4Exception-START: ELECTRONSCINTILLATIONYIELD   (Gumplinger Peter - 12 May, 2016)
(_ Question: Re: G4Exception-START: ELECTRONSCINTILLATIONYIELD   (Sergio Lo Meo - 13 May, 2016)
(_ Feedback: Re: G4Exception-START: ELECTRONSCINTILLATIONYIELD   (Gumplinger Peter - 13 May, 2016)
(_ Ok: Re: G4Exception-START: ELECTRONSCINTILLATIONYIELD   (Sergio Lo Meo - 22 May, 2016)
(_ Question: Re: G4Exception-START: ELECTRONSCINTILLATIONYIELD   (Nicholas DePorzio - 09 Aug, 2016)
(_ Feedback: Re: G4Exception-START: ELECTRONSCINTILLATIONYIELD   (Gumplinger Peter - 11 Aug, 2016)
 Add Message Add Message
to: "Re: G4Exception-START: ELECTRONSCINTILLATIONYIELD"

 Subscribe Subscribe

This site runs SLAC HyperNews version 1.11-slac-98, derived from the original HyperNews