Message: Problem with WLS fiber Not Logged In (login)
 Next-in-Thread Next-in-Thread
 Next-in-Forum Next-in-Forum

None Problem with WLS fiber 

Forum: Processes Involving Optical Photons
Date: 20 Aug, 2014
From: Nathan Murtha <Nathan Murtha>

Hello,

I'm a very new user to Geant4, and I'm trying to make a WLS fiber embedded in a scintillating plastic bar. I *think* that I have my detector built properly, and I *think* that I've properly set up my physics list - but I'm having problems, meaning that I've made a mistake that I can't see.

Optical photons are hitting my WLS fiber, but the fiber is not re-emitting any photons. I'm not familiar enough with Geant4 to know where to start looking for this problem, so I'm hoping that someone here might have an idea! I've attached my physics list (heavily cannibalized from an example) and my detector construction files to this post.

Thank you, Nathan

   Attachment:
      http://hypernews.slac.stanford.edu/HyperNews/geant4/get/AUX/2014/08/20/07.55-3822-ScintPhysicsList.cc
      http://hypernews.slac.stanford.edu/HyperNews/geant4/get/AUX/2014/08/20/07.59-42604-ntDetectorConstruction.cc

Inline Depth:
 1 1
 All All
Outline Depth:
 1 1
 2 2
 All All
Add message: (add)

1 Feedback: Re: Problem with WLS fiber   (Michael H. Kelsey - 20 Aug, 2014)
1 Question: Re: Problem with WLS fiber   (Nathan Murtha - 20 Aug, 2014)
1 Warning: Re: Problem with WLS fiber   (Michael H. Kelsey - 20 Aug, 2014)
... 3 Message(s)
2 Question: Re: Problem with WLS fiber   (Nathan Murtha - 20 Aug, 2014)
 Add Message Add Message
to: "Problem with WLS fiber"

 Subscribe Subscribe

This site runs SLAC HyperNews version 1.11-slac-98, derived from the original HyperNews