Message: Error linking examples: skipping incompatible /usr/X11R6/lib/libXmu.a when searching for -lXmu Not Logged In (login)
 Next-in-Thread Next-in-Thread
 Next-in-Forum Next-in-Forum

None Error linking examples: skipping incompatible /usr/X11R6/lib/libXmu.a when searching for -lXmu 

Keywords: Installation x86_64-suse-linux exampleN01
Forum: Installation and Configuration
Date: 22 Aug, 2007
From: David Wright <david.wright@yale.edu>

I've installed Geant4.9.0 on a Linux machine running Suse. The output of uname -a is

Linux He1 2.6.16.27-0.9-default #1 SMP Fri Jun 22 09:07:01 EDT 2007 x86_64 x86_64 x86_64 GNU/Linux

My gcc version is 4.1.0 (SuSE linux).

The installation appeared to be successful, but when I try to compile either Example N01 or N02, I get the following:

Using granular libraries ...

Linking exampleN01 ...

/usr/lib64/gcc/x86_64-suse-linux/4.1.0/../../../../x86_64-suse-linux/bin/ld: skipping incompatible /usr/X11R6/lib/libXmu.so when searching for -lXmu

/usr/lib64/gcc/x86_64-suse-linux/4.1.0/../../../../x86_64-suse-linux/bin/ld: skipping incompatible /usr/X11R6/lib/libXmu.a when searching for -lXmu

/usr/lib64/gcc/x86_64-suse-linux/4.1.0/../../../../x86_64-suse-linux/bin/ld: cannot find -lXmu

collect2: ld returned 1 exit status

make: *** [bin/Linux-g++/exampleN01] Error 1

Can anyone give me some advice as to how to fix this? Thanks, David

Inline Depth:
 1 1
 All All
Outline Depth:
 1 1
 2 2
 All All
Add message: (add)

1 None: Re: Error linking examples: skipping incompatible /usr/X11R6/lib/libXmu.a when searching for -lXmu   (Ben Morgan - 23 Aug, 2007)
1 None: Re: Error linking examples: skipping incompatible /usr/X11R6/lib/libXmu.a when searching for -lXmu   (niessen@ifh.de - 29 Aug, 2007)
3 None: Re: Error linking examples: skipping incompatible /usr/X11R6/lib/libXmu.a when searching for -lXmu   (sonal ambwani - 10 Apr, 2008)
 Add Message Add Message
to: "Error linking examples: skipping incompatible /usr/X11R6/lib/libXmu.a when searching for -lXmu"

 Subscribe Subscribe

This site runs SLAC HyperNews version 1.11-slac-98, derived from the original HyperNews


[ Geant 4 Home | Geant 4 HyperNews | Search | Request New Forum | Feedback ]