Message: Re: Error when installing Geant4 on a cluster. Not Logged In (login)
 Next-in-Thread Next-in-Thread
 Next-in-Forum Next-in-Forum

Question Re: Error when installing Geant4 on a cluster. 

Forum: Installation and Configuration
Re: Question Error when installing Geant4 on a cluster. (Huagang Yan)
Re: None Re: Error when installing Geant4 on a cluster.
Date: Jan 07, 19:03
From: Huagang Yan <Huagang Yan>

Thank you very much for your advice. I should have read the release notes before. I tried several combinations of icc versions and gcc versions. After I tried icc 16 and gcc 4.9.4, which had been tested by Geant4 group, the following error appeared. It should be the problem of the compiler, but I have no idea how to fix it. Someone suggested icc 17, but errors do not go away.

(in building libG4gl2ps.so) /usr/lib64/libGL.so: could not read symbols: file in wrong format ...

(in building libG4interfaces.so) /usr/lib64/libQtGui.so: could not read symbols: file in wrong format

I tried Geant4.10.5, but the installation was subject to conflict with https protocol, so I gave up.

On Mon, 07 Jan 2019 17:06:56 GMT, php1ic wrote:

> This looks to be an issue with the compiler you are using.
> 
> https://stackoverflow.com/questions/20152063/exception-specification-for-virtual-function-is-incompatible-with-that-of-overri
> 
> Does it match what has been tested by the geant4 team?
> 
> https://geant4-data.web.cern.ch/geant4-data/ReleaseNotes/ReleaseNotes4.10.4.html#1
> .
> 
> Does the problem go away if you use the new version (10.5), release in
> December?
> 

 Add Message Add Message
to: "Re: Error when installing Geant4 on a cluster."

 Subscribe Subscribe

This site runs SLAC HyperNews version 1.11-slac-98, derived from the original HyperNews


[ Geant 4 Home | Geant 4 HyperNews | Search | Request New Forum | Feedback ]