Message: Error when installing Geant4 on a cluster. Not Logged In (login)
 Next-in-Thread Next-in-Thread
 Next-in-Forum Next-in-Forum

Question Error when installing Geant4 on a cluster. 

Forum: Installation and Configuration
Date: Jan 04, 20:53
From: Huagang Yan <Huagang Yan>

The configuration goes smoothly, errors appear in the building stage. I referred to a paper by P. Schweitzer et. al.(Performance Evaluation of Multithreaded Geant4 Simulations Using an Intel Xeon Phi Cluster, Scientific Programming Volume 2015, Article ID 980752, 10 pages, http://dx.doi.org/10.1155/2015/980752) for the installation. The error message is as follows:

In file included from /public/home/hyan/software/geant4.10.04.p02/source/geometry/magneticfield/src/G4ChordFinder.cc(39):
/public/home/hyan/software/geant4.10.04.p02/source/geometry/magneticfield/include/G4MagIntegratorDriver.hh(55): error #809: exception specification for virtual function "G4MagInt_Driver::~G4MagInt_Driver" is incompatible with that of overridden function "G4VIntegrationDriver::~G4VIntegrationDriver"
      virtual ~G4MagInt_Driver() override;
              ^

/public/home/hyan/software/geant4.10.04.p02/source/geometry/magneticfield/include/G4FSALIntegrationDriver.hh(57): error #809: exception specification for virtual function "G4FSALIntegrationDriver<T>::~G4FSALIntegrationDriver [with T=G4RK547FEq1]" is incompatible with that of overridden function "G4VIntegrationDriver::~G4VIntegrationDriver"
      virtual ~G4FSALIntegrationDriver() override;
              ^

compilation aborted for /public/home/hyan/software/geant4.10.04.p02/source/geometry/magneticfield/src/G4ChordFinder.cc (code 2) make[2]: *** [source/geometry/CMakeFiles/G4geometry.dir/magneticfield/src/G4ChordFinder.cc.o] Error 2 make[1]: *** [source/geometry/CMakeFiles/G4geometry.dir/all] Error 2

Any advice is appreciated.

Inline Depth:
 1 1
 All All
Outline Depth:
 1 1
 2 2
 All All
Add message: (add)

1 None: Re: Error when installing Geant4 on a cluster.   (php1ic - Jan 07, 09:06)
(_ Question: Re: Error when installing Geant4 on a cluster.   (Huagang Yan - Jan 07, 19:03)
 Add Message Add Message
to: "Error when installing Geant4 on a cluster."

 Subscribe Subscribe

This site runs SLAC HyperNews version 1.11-slac-98, derived from the original HyperNews


[ Geant 4 Home | Geant 4 HyperNews | Search | Request New Forum | Feedback ]