Message: Upgrading program from G4 10.2 to G4 10.3 Not Logged In (login)
 Next-in-Thread Next-in-Thread
 Next-in-Forum Next-in-Forum

None Upgrading program from G4 10.2 to G4 10.3 

Forum: Installation and Configuration
Date: 14 Sep, 2018
From: Christopher Walker <Christopher Walker>

Hello,
   I am installing on Linux (GNU bash, version 4.4.19(1)-release (x86_64-pc-linux-gnu))

I have a program that runs under Geant4.10.02.p03 and I would like to update to the latest release. First I am trying to update to Geant4.10.03 and then to Geant4.10.04. I have never tried to update a Geant4 program before.

I compiled my program against Geant4.10.03 and I get the following error:
fatal error: G4EnergyLossMessenger.hh: No such file or directory
 #include "G4EnergyLossMessenger.hh"

I see that this file is present here: /geant4.10.02.p03/source/processes/electromagnetic/utils/include/G4EnergyLossMessenger.hh

but it is not present in the equivalent (or any other) directory for geant4.10.03

I have looked through the release notes and I find no mention of the removal of this file. In addition, it seems in the example eRosita: /geant4.10.03.p03/examples/advanced/eRosita/physics/include/G4eLowEnergyLoss.cc

still uses the file G4EnergyLossMessenger.hh

Hence I am rather confused, and not sure what to try next.

Thanks in advance Chris

 Add Message Add Message
to: "Upgrading program from G4 10.2 to G4 10.3"

 Subscribe Subscribe

This site runs SLAC HyperNews version 1.11-slac-98, derived from the original HyperNews


[ Geant 4 Home | Geant 4 HyperNews | Search | Request New Forum | Feedback ]