Message: Re: Problem building 10.5-beta on MacOSX with GDML (Xerces-C) support Not Logged In (login)
 Next-in-Thread Next-in-Thread
 Next-in-Forum Next-in-Forum

Feedback Re: Problem building 10.5-beta on MacOSX with GDML (Xerces-C) support 

Forum: Installation and Configuration
Re: Warning Problem building 10.5-beta on MacOSX with GDML (Xerces-C) support (Michael H. Kelsey)
Re: Question Re: Problem building 10.5-beta on MacOSX with GDML (Xerces-C) support (Ben Morgan)
Re: More Re: Problem building 10.5-beta on MacOSX with GDML (Xerces-C) support (Michael H. Kelsey)
Re: Question Re: Problem building 10.5-beta on MacOSX with GDML (Xerces-C) support (Ben Morgan)
Date: 25 Jul, 2018
From: Michael H. Kelsey <Michael H. Kelsey>

On Wed, 25 Jul 2018 08:46:16 GMT, Ben Morgan wrote:
> On Tue, 24 Jul 2018 14:19:47 GMT, Michael H. Kelsey wrote:
> > Hi, Ben. I installed Xerces-C using their direct |./configure| and |make
> > install| actions, as described in their installation instructions.
> > 
> > The reference to libxercesc.a above was my attempt to get around these
> > link errors: I have been using libxercesc.dylib (from their 3.1 release)
> > successfully with all Geant4 builds (going back to 9.4!), including
> > 10.4-patch-02. It's only the 10.5 build which started showing these
> > failures, so I tried (a) switching from shared to static, and (b)
> > upgrading from 3.1 to 3.2.1.
> 
> Do you see the same issues (and could you post the error messages if so)
> with dylibs? What's the output of otool -L /path/to/your/libxerces-c-3.2.dylib ?

{michaels-mbp:90} otool -L libxerces-c-3.2.dylib
libxerces-c-3.2.dylib:
	/usr/local/xerces/lib/libxerces-c-3.2.dylib (compatibility version 0.0.0, current version 0.0.0)
	/usr/lib/libSystem.B.dylib (compatibility version 1.0.0, current version 1252.50.4)
	/usr/lib/libcurl.4.dylib (compatibility version 7.0.0, current version 9.0.0)
	/System/Library/Frameworks/CoreServices.framework/Versions/A/CoreServices (compatibility version 1.0.0, current version 822.36.0)
	/usr/lib/libc++.1.dylib (compatibility version 1.0.0, current version 400.9.0)
	/System/Library/Frameworks/CoreFoundation.framework/Versions/A/CoreFoundation (compatibility version 150.0.0, current version 1454.90.0)

> This feels more like an issue with the xerces install than with Geant4.

That's what I thought (would have thought) as well, except that I didn't have any of these problems until the 10.5-beta build. Maybe there's something new that's been introduced to support GDML?

  -- Mike

Inline Depth:
 1 1
 All All
Outline Depth:
 1 1
 2 2
 All All
Add message: (add)

1 None: Re: Problem building 10.5-beta on MacOSX with GDML (Xerces-C) support   (Ben Morgan - 26 Jul, 2018)
(_ Ok: Re: Problem building 10.5-beta on MacOSX with GDML (Xerces-C) support   (Michael H. Kelsey - Dec 07, 15:19)
 Add Message Add Message
to: "Re: Problem building 10.5-beta on MacOSX with GDML (Xerces-C) support"

 Subscribe Subscribe

This site runs SLAC HyperNews version 1.11-slac-98, derived from the original HyperNews


[ Geant 4 Home | Geant 4 HyperNews | Search | Request New Forum | Feedback ]