Message: More QT installation issues. One for Laurent? Not Logged In (login)
 Next-in-Thread Next-in-Thread
 Next-in-Forum Next-in-Forum

None More QT installation issues. One for Laurent? 

Forum: Installation and Configuration
Date: 05 Mar, 2018
From: Tim Fulcher <Tim Fulcher>

Hi All

I'm trying to get Geant installed and use QT for visualisation (I've been using it with OpenGL and HepRep for some time).

Here's my cmake install script:

cmake -DCMAKE_INSTALL_PREFIX=/usr/local -DGEANT4_INSTALL_DATA=ON -DGEANT4_USE_OPENGL_X11=ON -DGEANT_USE_QT=ON -DCMAKE_PREFIX_PATH=/usr/bin -DGEANT4_INSTALL_EXAMPLES=ON -DBUILD_SHARED_LIBS=ON -DBUILD_STATIC_LIBS=ON /home/tim/geant4.10.04

but it returns with this:

-- The C compiler identification is GNU 5.4.0
-- The CXX compiler identification is GNU 5.4.0
-- Check for working C compiler: /usr/bin/cc
-- Check for working C compiler: /usr/bin/cc -- works
-- Detecting C compiler ABI info
-- Detecting C compiler ABI info - done
-- Detecting C compile features
-- Detecting C compile features - done
-- Check for working CXX compiler: /usr/bin/c++
-- Check for working CXX compiler: /usr/bin/c++ -- works
-- Detecting CXX compiler ABI info
-- Detecting CXX compiler ABI info - done
-- Detecting CXX compile features
-- Detecting CXX compile features - done
-- Found EXPAT: /usr/lib/x86_64-linux-gnu/libexpat.so (found version "2.1.0")
-- Looking for XOpenDisplay in /usr/lib/x86_64-linux-gnu/libX11.so;/usr/lib/x86_64-linux-gnu/libXext.so
-- Looking for XOpenDisplay in /usr/lib/x86_64-linux-gnu/libX11.so;/usr/lib/x86_64-linux-gnu/libXext.so - found
-- Looking for gethostbyname
-- Looking for gethostbyname - found
-- Looking for connect
-- Looking for connect - found
-- Looking for remove
-- Looking for remove - found
-- Looking for shmat
-- Looking for shmat - found
-- Looking for IceConnectionNumber in ICE
-- Looking for IceConnectionNumber in ICE - found
-- Found X11: /usr/lib/x86_64-linux-gnu/libX11.so
-- Found OpenGL: /usr/lib/x86_64-linux-gnu/libGL.so
-- Looking for sys/types.h
-- Looking for sys/types.h - found
-- Looking for stdint.h
-- Looking for stdint.h - found
-- Looking for stddef.h
-- Looking for stddef.h - found
-- Check size of off64_t
-- Check size of off64_t - done
-- Looking for fseeko
-- Looking for fseeko - found
-- Looking for unistd.h
-- Looking for unistd.h - found
-- Reusing dataset G4NDL (4.5)
-- Reusing dataset G4EMLOW (7.3)
-- Reusing dataset PhotonEvaporation (5.2)
-- Reusing dataset RadioactiveDecay (5.2)
-- Reusing dataset G4NEUTRONXS (1.4)
-- Reusing dataset G4PII (1.3)
-- Reusing dataset RealSurface (2.1)
-- Reusing dataset G4SAIDDATA (1.1)
-- Reusing dataset G4ABLA (3.1)
-- Reusing dataset G4ENSDFSTATE (2.2)
-- The following Geant4 features are enabled:
GEANT4_BUILD_CXXSTD: Compiling against C++ Standard '11'
GEANT4_USE_SYSTEM_EXPAT: Using system EXPAT library
GEANT4_USE_OPENGL_X11: Build Geant4 OpenGL driver with X11 support

-- Configuring done
-- Generating done
CMake Warning:
  Manually-specified variables were not used by the project:

    GEANT_USE_QT


-- Build files have been written to: /home/tim/geant4.10.04-build

Bitter experience has taught me not to go ahead and make this because it won't install/configure Geant for QT.

Any hints or tips?

Regards

Tim

Inline Depth:
 1 1
 All All
Outline Depth:
 1 1
 2 2
 All All
Add message: (add)

1 Ok: Re: More QT installation issues. One for Laurent?   (Garnier Laurent - 26 Mar, 2018)
 Add Message Add Message
to: "More QT installation issues. One for Laurent?"

 Subscribe Subscribe

This site runs SLAC HyperNews version 1.11-slac-98, derived from the original HyperNews


[ Geant 4 Home | Geant 4 HyperNews | Search | Request New Forum | Feedback ]