Message: install Geant4 with intel compiler version 17.0.4 (gcc version 4.8.5 compatibility) Not Logged In (login)
 Next-in-Thread Next-in-Thread
 Next-in-Forum Next-in-Forum

Question install Geant4 with intel compiler version 17.0.4 (gcc version 4.8.5 compatibility) 

Forum: Installation and Configuration
Date: 18 Jul, 2017
From: Mikhail <Mikhail>

I have managed to compile G4 10.02 on SL6 with intel compiler version 17.0.4, it runs, but obtained results are fairly different from normal gcc build. In particular distributions of energy deposited look wrong, it seems that random number generation is broken (same values of angular distribution repeated many times). I have seen similar behavior with gcc when random seeds were not initialized (MPI app.). Any idea why random numbers don't work on intel icc?

Inline Depth:
 1 1
 All All
Outline Depth:
 1 1
 2 2
 All All
Add message: (add)

1 Feedback: Re: install Geant4 with intel compiler version 17.0.4 (gcc version 4.8.5 compatibility)   (Andrea Dotti - 18 Jul, 2017)
 Add Message Add Message
to: "install Geant4 with intel compiler version 17.0.4 (gcc version 4.8.5 compatibility)"

 Subscribe Subscribe

This site runs SLAC HyperNews version 1.11-slac-98, derived from the original HyperNews


[ Geant 4 Home | Geant 4 HyperNews | Search | Request New Forum | Feedback ]