Message: problem compiling a g4 simulation Not Logged In (login)
 Next-in-Thread Next-in-Thread
 Next-in-Forum Next-in-Forum

Question problem compiling a g4 simulation 

Forum: Installation and Configuration
Date: 25 May, 2017
From: Aleksey Sher <Aleksey Sher>

Hello, I just successfully compiled g4.10.03.p01

but when I try to compile my simulation code, I get the following error:

/usr/bin/ld: cannot find -lG4emdna-utils

I checked, and in the lib directory I have other libraries, but not the G4emdna-utils

below is what I have:

bash-3.2$ ls /kdecay/data48/sher/geant4.10.03.p01-install/lib64/Linux-g++/*emd* /kdecay/data48/sher/geant4.10.03.p01-install/lib64/Linux-g++/libG4emdna-models.so /kdecay/data48/sher/geant4.10.03.p01-install/lib64/Linux-g++/libG4emdna-molman.so /kdecay/data48/sher/geant4.10.03.p01-install/lib64/Linux-g++/libG4emdna-moltypes.so /kdecay/data48/sher/geant4.10.03.p01-install/lib64/Linux-g++/libG4emdna-processes.so

any help would be appreciated

Inline Depth:
 1 1
 All All
Outline Depth:
 1 1
 2 2
 All All
Add message: (add)

1 Ok: Re: problem compiling a g4 simulation   (Aleksey Sher - 01 Jun, 2017)
 Add Message Add Message
to: "problem compiling a g4 simulation"

 Subscribe Subscribe

This site runs SLAC HyperNews version 1.11-slac-98, derived from the original HyperNews


[ Geant 4 Home | Geant 4 HyperNews | Search | Request New Forum | Feedback ]