Message: Problem at installation phase Not Logged In (login)
 Next-in-Thread Next-in-Thread
 Next-in-Forum Next-in-Forum

Question Problem at installation phase 

Forum: Installation and Configuration
Date: 24 May, 2017
From: Aleksey Sher <Aleksey Sher>

Hello, I am having trouble with the installation.

here is a part that shows that dependencies are satisfied:

bash-3.2$ gcc -v Using built-in specs. COLLECT_GCC=gcc COLLECT_LTO_WRAPPER=/usr/local/libexec/gcc/x86_64-unknown-linux-gnu/4.8.2/lto-wrapper Target: x86_64-unknown-linux-gnu Configured with: ../gcc-4.8.2/configure Thread model: posix gcc version 4.8.2 (GCC) bash-3.2$ cmake --version cmake version 3.8.0-rc2

CMake suite maintained and supported by Kitware (kitware.com/cmake).

later on, the errors start to accumulate at the cmake phase:

after I do:

bash-3.2$ pwd /data48/sher/geant4.10.03.p01-build bash-3.2$ cmake -DCMAKE_INSTALL_PREFIX=/data48/sher/geant4.10.03.p01-install /data48/sher/geant4.10.03.p01

I get errors still, here is a bit of the errors:

Call Stack (most recent call first):
  cmake/Modules/Geant4MacroLibraryTargets.cmake:300 (GEANT4_LIBRARY_TARGET)
  source/visualization/RayTracer/CMakeLists.txt:25 (GEANT4_GLOBAL_LIBRARY_TARGET)

CMake Error at cmake/Modules/Geant4MacroLibraryTargets.cmake:111 (target_compile_features):
  target_compile_features no known features for CXX compiler

  "GNU"

  version 4.1.2.
Call Stack (most recent call first):
  cmake/Modules/Geant4MacroLibraryTargets.cmake:300 (GEANT4_LIBRARY_TARGET)
  source/visualization/Tree/CMakeLists.txt:18 (GEANT4_GLOBAL_LIBRARY_TARGET)

CMake Error at cmake/Modules/Geant4MacroLibraryTargets.cmake:111 (target_compile_features):
  target_compile_features no known features for CXX compiler

  "GNU"

  version 4.1.2.
Call Stack (most recent call first):
  cmake/Modules/Geant4MacroLibraryTargets.cmake:300 (GEANT4_LIBRARY_TARGET)
  source/visualization/VRML/CMakeLists.txt:18 (GEANT4_GLOBAL_LIBRARY_TARGET)

CMake Error at cmake/Modules/Geant4MacroLibraryTargets.cmake:111 (target_compile_features):
  target_compile_features no known features for CXX compiler

  "GNU"

  version 4.1.2.
Call Stack (most recent call first):
  cmake/Modules/Geant4MacroLibraryTargets.cmake:300 (GEANT4_LIBRARY_TARGET)
  source/visualization/XXX/CMakeLists.txt:18 (GEANT4_GLOBAL_LIBRARY_TARGET)

CMake Error at cmake/Modules/Geant4MacroLibraryTargets.cmake:111 (target_compile_features):
  target_compile_features no known features for CXX compiler

  "GNU"

  version 4.1.2.
Call Stack (most recent call first):
  cmake/Modules/Geant4MacroLibraryTargets.cmake:300 (GEANT4_LIBRARY_TARGET)
  source/visualization/gMocren/CMakeLists.txt:18 (GEANT4_GLOBAL_LIBRARY_TARGET)

CMake Error at cmake/Modules/Geant4MacroLibraryTargets.cmake:111 (target_compile_features):
  target_compile_features no known features for CXX compiler

  "GNU"

  version 4.1.2.
Call Stack (most recent call first):
  cmake/Modules/Geant4MacroLibraryTargets.cmake:300 (GEANT4_LIBRARY_TARGET)
  source/visualization/management/CMakeLists.txt:18 (GEANT4_GLOBAL_LIBRARY_TARGET)

CMake Error at cmake/Modules/Geant4MacroLibraryTargets.cmake:111 (target_compile_features):
  target_compile_features no known features for CXX compiler

  "GNU"

  version 4.1.2.
Call Stack (most recent call first):
  cmake/Modules/Geant4MacroLibraryTargets.cmake:300 (GEANT4_LIBRARY_TARGET)
  source/visualization/modeling/CMakeLists.txt:18 (GEANT4_GLOBAL_LIBRARY_TARGET)

Although I do notice that the reported errors are from 4.1.2, which is strange....

any advice would be appreciated.

Inline Depth:
 1 1
 All All
Outline Depth:
 1 1
 2 2
 All All
Add message: (add)

1 Ok: Re: Problem at installation phase   (Aleksey Sher - 24 May, 2017)
(_ Warning: Re: Problem at installation phase   (Aleksey Sher - 25 May, 2017)
 Add Message Add Message
to: "Problem at installation phase"

 Subscribe Subscribe

This site runs SLAC HyperNews version 1.11-slac-98, derived from the original HyperNews


[ Geant 4 Home | Geant 4 HyperNews | Search | Request New Forum | Feedback ]