Message: problem with LBE in 10.3.1 Not Logged In (login)
 Next-in-Thread Next-in-Thread
 Next-in-Forum Next-in-Forum

Question problem with LBE in 10.3.1 

Forum: Installation and Configuration
Date: 28 Apr, 2017
From: Nicola Pozzobon <Nicola Pozzobon>

Hi, I recently had problems in running a G4-based simulation of a scintillator calorimeter featuring optical photon processes in addition to the LBE physics list, as I found it to be the only pre-defined physics list that lets optical photons be simulated (e.g. the scintillator does not scintillate with QGSP_* + optical photons...)

Since 10.3 I cannot run anything with LBE physics list, because of G4RadioactiveDecay::BuildPhysicsTable( ... ) (lines from 722 of https://github.com/Geant4/geant4/blob/geant4-10.3-release/source/processes/hadronic/models/radioactive_decay/src/G4RadioactiveDecay.cc )

I also tried modifying several examples provided with the G4 source, replacing their physics list with LBE, and they result into the previously mentioned fatal error.

How can I fix this?

Thank you very much

Nicola

 Add Message Add Message
to: "problem with LBE in 10.3.1"

 Subscribe Subscribe

This site runs SLAC HyperNews version 1.11-slac-98, derived from the original HyperNews


[ Geant 4 Home | Geant 4 HyperNews | Search | Request New Forum | Feedback ]