Message: Re: compilation error geant4 on macos sierra Not Logged In (login)
 Next-in-Thread Next-in-Thread
 Next-in-Forum Next-in-Forum

Warning Re: compilation error geant4 on macos sierra 

Forum: Installation and Configuration
Re: None compilation error geant4 on macos sierra (Eric Simiele)
Date: 23 Sep, 2016
From: Gabriele Cosmo <Gabriele Cosmo>

The MT build on MacOS after upgrade to the latest XCode (XCode-8) is
broken. This is due to internal upgrade of the clang compiler which comes
with XCode-8.
I strongly suggest NOT to upgrade to XCode-8 if you rely on MT (sequential
build should still be OK), even on MacOS El-Capitan.
These issues can eventually only be addressed by the final release 10.3 of
Geant4, planned for December this year.

Cheers, Gabriele

----------------
On Thu, 22 Sep 2016 21:32:46 GMT, Eric Simiele wrote:
> Hey mac users,
> 
> Many of you have probably noticed the large number of updates that have
> recently become available for mac users (mainly macOS sierra and an
> Xcode update). After updating both, I went to try and recompile geant4
> (because it requires a pointer to a valid .sdk file), but I can no
> longer compile in multithreading mode. See the attached file for the
> error message. I get this error message whether I try to compile in
> multithreaded mode using geant4.10.02-p02 or geant4.10.03.b01 as the
> source code. Unfortunately, I'm not sure if it was due to the Xcode
> update or the OS update or both. If anyone has any suggestions to fix
> this problem I would be very grateful. See the other attached file for
> my attempted cmake configuration.
> 
> Thankfully, I have a backup of my mac before the upgrade so I'll
> probably restore from my previous backup if I can't figure out a
> solution.
> 
> Eric
> 
>    Attachment:
>       http://hypernews.slac.stanford.edu/HyperNews/geant4/get/AUX/2016/09/22/14.27-12246-6-09-22_at_4.16.42_PM.png
>       http://hypernews.slac.stanford.edu/HyperNews/geant4/get/AUX/2016/09/22/14.27-27-6-09-22_at_4.17.05_PM.png
> 

Inline Depth:
 1 1
 All All
Outline Depth:
 1 1
 2 2
 All All
Add message: (add)

1 Idea: Re: compilation error geant4 on macos sierra   (Eric Simiele - 24 Sep, 2016)
 Add Message Add Message
to: "Re: compilation error geant4 on macos sierra"

 Subscribe Subscribe

This site runs SLAC HyperNews version 1.11-slac-98, derived from the original HyperNews


[ Geant 4 Home | Geant 4 HyperNews | Search | Request New Forum | Feedback ]