Message: Geant4 build problem on Win 7/ Visual Studio 2015 Not Logged In (login)
 Next-in-Thread Next-in-Thread
 Next-in-Forum Next-in-Forum

None Geant4 build problem on Win 7/ Visual Studio 2015 

Forum: Installation and Configuration
Date: 17 Sep, 2016
From: Kaloyan Metodiev <Kaloyan Metodiev>

Hi,

I downloaded geant4 version 10.2.(patch 02) and it gives an error while building with Visual Studio 2015 of the sort: (I have seen that in a post before on this site.)

fatal error LINK 1189: "library limit exceeds 65535 objects" (I have seen that in a post before on this site --> http://hypernews.slac.stanford.edu/HyperNews/geant4/get/installconfig/1778.html?inline=1)

That is for the G4processes library (and it makes sense maybe since the .def file in that project has ~74000 objects) and from there some other libraries are unable to build as well. From what I read, I thought that the libraries should be split in v10.3. However, I have downloaded the beta version Geant 10.3, but it still gives the same error at the same place. Maybe I am doing something wrong?

Inline Depth:
 1 1
 All All
Outline Depth:
 1 1
 2 2
 All All
Add message: (add)

1 None: Re: Geant4 build problem on Win 7/ Visual Studio 2015   (Tom Roberts - 17 Sep, 2016)
2 None: Re: Geant4 build problem on Win 7/ Visual Studio 2015   (Ben Morgan - 19 Sep, 2016)
 Add Message Add Message
to: "Geant4 build problem on Win 7/ Visual Studio 2015"

 Subscribe Subscribe

This site runs SLAC HyperNews version 1.11-slac-98, derived from the original HyperNews


[ Geant 4 Home | Geant 4 HyperNews | Search | Request New Forum | Feedback ]