Message: Re: G4 OpenGL module compilation broken on Linux Not Logged In (login)
 Next-in-Thread Next-in-Thread
 Next-in-Forum Next-in-Forum

Note Re: G4 OpenGL module compilation broken on Linux 

Forum: Installation and Configuration
Re: Question G4 OpenGL module compilation broken on Linux (Jeremy McCormick)
Date: 19 Aug, 2016
From: Ben Morgan <Ben Morgan>

On Tue, 16 Aug 2016 23:12:38 GMT, Jeremy McCormick wrote:
> [100%] Building CXX object source/visualization/OpenGL/CMakeFiles/G4OpenGL.dir/src/G4OpenGLImmediateViewer.cc.o
> In file included from /work/scratch/geant4.10.02.p01/source/visualization/OpenGL/include/G4OpenGLImmediateViewer.hh:40:0,
>                  from /work/scratch/geant4.10.02.p01/source/visualization/OpenGL/src/G4OpenGLImmediateViewer.cc:37:
> /work/scratch/geant4.10.02.p01/source/visualization/OpenGL/include/G4OpenGLViewer.hh:155:25: error: 'GLdouble' has not been declared
>    virtual G4String Pick(GLdouble x, GLdouble y);                          
> 
> The errors seem to indicate that it is not properly including one or more of the basic OpenGL header files.

Could you re-run the build with

$ make G4OpenGL VERBOSE=1

which will print the exact command and flags used to compile the code, and post the output of the failing compilation here please? Looking at the logic in the build and the source code, the inclusion of the relevant GL header should be happening. I'd like to see the exact compile command to check that the relevant preprocessor and include paths are being set.

Cheers,

Ben

 Add Message Add Message
to: "Re: G4 OpenGL module compilation broken on Linux"

 Subscribe Subscribe

This site runs SLAC HyperNews version 1.11-slac-98, derived from the original HyperNews


[ Geant 4 Home | Geant 4 HyperNews | Search | Request New Forum | Feedback ]