Message: Many warnings when compile Geant4_10_02_p02 on Win7 with VS2015 Not Logged In (login)
 Next-in-Thread Next-in-Thread
 Next-in-Forum Next-in-Forum

None Many warnings when compile Geant4_10_02_p02 on Win7 with VS2015  

Forum: Installation and Configuration
Date: 25 Jul, 2016
From: <hli.thu11@gmail.com>

Hello everyone,

I am trying to install Geant4_10_02_p2 on Windows7 with VS2015/CMake3.6.0. I got many C4311 and LNK4221 warnings like below:

30>d:\soft\geant4\source\source\analysis\g4tools\include\tools\value(693): warning C4311: 'type cast': pointer truncation from 'void *const ' to 'unsigned long'

8>G4UPolyhedra.obj : warning LNK4221: This object file does not define any previously undefined public symbols, so it will not be used by any link operation that consumes this library

Any help will be much appreciated.

   Attachment:
      http://hypernews.slac.stanford.edu/HyperNews/geant4/get/AUX/2016/07/25/18.32-30609-output.txt

Inline Depth:
 1 1
 All All
Outline Depth:
 1 1
 2 2
 All All
Add message: (add)

1 None: Re: Many warnings when compile Geant4_10_02_p02 on Win7 with VS2015   (Tom Roberts - 25 Jul, 2016)
1 None: Re: Many warnings when compile Geant4_10_02_p02 on Win7 with VS2015   (hli.thu11@gmail.com - 25 Jul, 2016)
2 Ok: Re: Many warnings when compile Geant4_10_02_p02 on Win7 with VS2015   (hli.thu11@gmail.com - 26 Jul, 2016)
 Add Message Add Message
to: "Many warnings when compile Geant4_10_02_p02 on Win7 with VS2015 "

 Subscribe Subscribe

This site runs SLAC HyperNews version 1.11-slac-98, derived from the original HyperNews


[ Geant 4 Home | Geant 4 HyperNews | Search | Request New Forum | Feedback ]