Message: Re: Could NOT find EXPAT Not Logged In (login)
 Next-in-Thread Next-in-Thread
 Next-in-Forum Next-in-Forum

None Re: Could NOT find EXPAT 

Forum: Installation and Configuration
Re: None Could NOT find EXPAT (Mark Crain)
Re: None Re: Could NOT find EXPAT (Mark Crain)
Re: None Re: Could NOT find EXPAT (Ben Morgan)
Re: None Re: Could NOT find EXPAT (Mark Crain)
Date: 17 Jun, 2016
From: Ben Morgan <Ben Morgan>

Hi Mark,

I am not 100% sure on where Debian(?) puts everything, but I would expect that for Geant4 to find expat, the system should at least have the files:

  • /usr/include/expat.h
  • /usr/lib{64}/.../libexpat.so

The location of libexpat.so will depend on exactly how you setup the system, but it should be under one of the /usr/libSOMETHING directories.

If these aren't present, cross check which packages for expat you have installed, and which ones supply the requisite files. If they are present, try removing the build directory for Geant4 and starting from scratch (just in case of cache issues).

If none of these solve things, then Geant4 does supply a builtin copy of expat for cases like this. This can be activated by passing -DGEANT4_USE_SYSTEM_EXPAT=OFF to cmake together with the other arguments. It's better to use the system expat for ease, but the builtin version should get you up and running (though if expat isn't installed, you may find other system packages are missing, but first things first).

Ben.

Inline Depth:
 1 1
 All All
Outline Depth:
 1 1
 2 2
 All All
Add message: (add)

1 None: Re: Could NOT find EXPAT   (Mark Crain - 17 Jun, 2016)
 Add Message Add Message
to: "Re: Could NOT find EXPAT"

 Subscribe Subscribe

This site runs SLAC HyperNews version 1.11-slac-98, derived from the original HyperNews


[ Geant 4 Home | Geant 4 HyperNews | Search | Request New Forum | Feedback ]