Message: Re: Geant4/Qt installation error Not Logged In (login)
 Next-in-Thread Next-in-Thread
 Next-in-Forum Next-in-Forum

None Re: Geant4/Qt installation error 

Forum: Installation and Configuration
Re: Question Geant4/Qt installation error (Carolina Cechinel)
Date: 02 Jun, 2016
From: Garnier Laurent <Garnier Laurent>

Hi Carolina,

All seems correct except:

> -DQT_QMAKE_EXECUTABLE=/Users/carolinacechinel/software/Qt/5.6/clang_64/bin/qmake
> -DCMAKE_PREFIX_PATH=/Users/carolinacechinel/software/Qt

The first thing cmake will look into is the CMAKE_PREFIX_PATH, in your case, it will look into "/Users/carolinacechinel/software/Qt" but it will not find your version (it could not guess if you have 5.6, 5.5 or others).

You should put instead (this is the location of your qmake file) -DCMAKE_PREFIX_PATH=/Users/carolinacechinel/software/Qt/5.6/clang_64/bin

And that's all, forget about -DQT_QMAKE_EXECUTABLE, it will be automaticaly fill.

Cheers,

Laurent

On Wed, 01 Jun 2016 21:46:59 GMT, Carolina Cechinel wrote:

> I&#65533;m trying to install the Geant4 10.2 first released 4 December 2015
> (patch-01, released 26 February 2016) on a mac OS X. I also got the QT
> 5.6 (qt-unified-mac-x64-2.0.3-online.dmg).
> 
> I'm typing this command:
> 
> cmake
> -DCMAKE_INSTALL_PREFIX=/Users/carolinacechinel/software/geant4.10.02.p01-install
> -DGEANT4_INSTALL_DATA=ON -DGEANT4_USE_QT=ON
> -DQT_QMAKE_EXECUTABLE=/Users/carolinacechinel/software/Qt/5.6/clang_64/bin/qmake
> -DCMAKE_PREFIX_PATH=/Users/carolinacechinel/software/Qt
> -DGEANT4_USE_SYSTEM_EXPAT=OFF -DGEANT4_FORCE_QT4=OFF
> /Users/carolinacechinel/software/geant4.10.02.p01
> 
> And I&#65533;m having this error:
> 
> CMake Error at
> /Users/carolinacechinel/software/cmake_install/share/cmake-3.5/Modules/FindQt4.cmake:1326
> (message):
> 
>   Found unsuitable Qt version "5.6.0" from
> 
>   /Users/carolinacechinel/software/Qt/5.6/clang_64/bin/qmake, this code
> 
>   requires Qt 4.x
> 
> Call Stack (most recent call first):
> 
>   cmake/Modules/Geant4InterfaceOptions.cmake:117 (find_package)
> 
>   CMakeLists.txt:80 (include)
> 
> -- Configuring incomplete, errors occurred!
> 
> See also
> "/Users/carolinacechinel/software/geant4.10.02.p01-build/CMakeFiles/CMakeOutput.log&#65533;.
> 
> I will be glad to have assistance for this error.
> 
> Carolina
> 

 Add Message Add Message
to: "Re: Geant4/Qt installation error"

 Subscribe Subscribe

This site runs SLAC HyperNews version 1.11-slac-98, derived from the original HyperNews


[ Geant 4 Home | Geant 4 HyperNews | Search | Request New Forum | Feedback ]