Message: Geant4 10.2.p01 Win 7 and VC2015 installation problem Not Logged In (login)
 Next-in-Thread Next-in-Thread
 Next-in-Forum Next-in-Forum

None Geant4 10.2.p01 Win 7 and VC2015 installation problem  

Forum: Installation and Configuration
Date: 26 May, 2016
From: Seb Galer <Seb Galer>

Hi,

I'm trying to install the latest version of Geant4 onto my windows 7 PC by following the installation guide provided. I have cmake (v3.4.2) installed and visual studio 2015 (express but this has always worked in the past) and get as far as the cmake configure step without any problems. When I try to build and/install however I get a huge number of errors. They seem to be mainly centered around the G4Threading.hh file and not being able to find the unistd.h file (and the same named file from multiple locations).

I also get what looks like errors in the code (I'm assuming that these are knock-on problems) as it reports problems such as missing brackets or undefined variables.

Any help would be much appreciated.

Seb




--
If you have received this message in error, please notify us and remove it from your system.
NPL Management Ltd cannot guarantee that the e-mail or any attachments are free from viruses.
 
NPL Management Ltd is a company registered in England and Wales, number: 2937881
Registered office: National Physical Laboratory | Hampton Road | Teddington, Middlesex | UK | TW11 0LW


 [ MIME part of type text/html without a name stripped ]

   Attachment:
     http://hypernews.slac.stanford.edu/HyperNews/geant4/get/AUX/2016/05/26/04.28-32467-npl-logo.jpg

   Attachment:
     http://hypernews.slac.stanford.edu/HyperNews/geant4/get/AUX/2016/05/26/04.28-48677-twitter.jpg

   Attachment:
     http://hypernews.slac.stanford.edu/HyperNews/geant4/get/AUX/2016/05/26/04.28-96140-facebook.jpg

   Attachment:
     http://hypernews.slac.stanford.edu/HyperNews/geant4/get/AUX/2016/05/26/04.28-47045-youtube.jpg

 Add Message Add Message
to: "Geant4 10.2.p01 Win 7 and VC2015 installation problem "

 Subscribe Subscribe

This site runs SLAC HyperNews version 1.11-slac-98, derived from the original HyperNews


[ Geant 4 Home | Geant 4 HyperNews | Search | Request New Forum | Feedback ]