Message: Re: Geant4 10.2 and g++ version Not Logged In (login)
 Next-in-Thread Next-in-Thread
 Next-in-Forum Next-in-Forum

Question Re: Geant4 10.2 and g++ version 

Forum: Installation and Configuration
Re: Warning Geant4 10.2 and g++ version (Tom Roberts)
Date: 24 May, 2016
From: Ben Morgan <Ben Morgan>

On Mon, 23 May 2016 15:48:24 GMT, Tom Roberts wrote:
> Geant4 10.2 now requires gcc/g++ version 4.8.3 or later.
> 
> Unfortunately, there is not a supported version of Scientific Linux
> Fermi that has such a recent compiler. So Fermilab users must install
> the development toolchain manually, which has alligators....
>
> It does build on Mac OS X 10.9.5 (Mavericks) and later, and on Windows 7
> using VC++ 2015. Of course neither of these use gcc.
>

This should all be clearly laid out in both the Release Notes and Installation Guide. If there is something in those that requires clarification, please let us know.

On Linux, and specifically the RHEL6/7 family, of which SLF is presumably binary compatible, then as noted in the Installation Guide, Software Collections can be used to install an up-to-date gcc 4.8/4.9 (and even 5) toolchain. Whilst this is straying slightly into site-specific setups, it is my understanding that FNAL Computing provide installs of newer GCCs via the UPS mechanism.

 Add Message Add Message
to: "Re: Geant4 10.2 and g++ version"

 Subscribe Subscribe

This site runs SLAC HyperNews version 1.11-slac-98, derived from the original HyperNews


[ Geant 4 Home | Geant 4 HyperNews | Search | Request New Forum | Feedback ]