Message: Compilation issues on Windows 10 using Visual Studio 2015 Not Logged In (login)
 Next-in-Thread Next-in-Thread
 Next-in-Forum Next-in-Forum

None Compilation issues on Windows 10 using Visual Studio 2015 

Forum: Installation and Configuration
Date: 14 Apr, 2016
From: Youming Yang <Youming Yang>

Hello,

I am trying to install Geant4 on W10 using VS2015. I have been using 10.01 and VS2010 until now without issue. Recently tried to install 10.02 (and 10.01) using VS2015 and came across the following:

Cannot compile 10.02/VS2015 in debug mode, running into the aforementioned number of debug symbols exceeding ~max_ushort.

Tried to go with 10.01/VS2010 instead (again in debug mode). I have attached the output, but the relevant issues are that it fails at compilation of xmlparse.cc:

18>C:\geant\geant4_10_01_p03\source\externals\expat\src\xmlparse.cc(1912): error C3688: invalid literal suffix 'L'; literal operator or literal operator template 'operator ""L' not found
18>  xmlrole.cc

After which, all a variety of linker issues arise when they need to refer to the expat library:

23>LINK : fatal error LNK1104: cannot open file '..\..\..\outputs\archive\Debug\_G4expat-archive.lib' 59>LINK : fatal error LNK1104: cannot open file '..\..\outputs\archive\Debug\G4expat.lib'

This error then propagates into the G4processes build, etc, resulting in ~20 linker errors at the end total

It's a fresh W10 install, with only the "install data" flag checked, and compiling in Debug. Could someone help me with why this is happening?

I will try to find dig up an installer for VS2010 in the mean time.

Thanks in advance, Ming

   Attachment:
      http://hypernews.slac.stanford.edu/HyperNews/geant4/get/AUX/2016/04/14/23.05-84470-output.txt

Inline Depth:
 1 1
 All All
Outline Depth:
 1 1
 2 2
 All All
Add message: (add)

1 None: Re: Compilation issues on Windows 10 using Visual Studio 2015   (Youming Yang - 23 Apr, 2016)
(_ Question: Re: Compilation issues on Windows 10 using Visual Studio 2015   (hli.thu11@gmail.com - 25 Jul, 2016)
(_ None: Re: Compilation issues on Windows 10 using Visual Studio 2015   (Youming Yang - 13 Aug, 2016)
(_ None: Re: Compilation issues on Windows 10 using Visual Studio 2015   (hli.thu11@gmail.com - 23 Aug, 2016)
 Add Message Add Message
to: "Compilation issues on Windows 10 using Visual Studio 2015"

 Subscribe Subscribe

This site runs SLAC HyperNews version 1.11-slac-98, derived from the original HyperNews


[ Geant 4 Home | Geant 4 HyperNews | Search | Request New Forum | Feedback ]