Message: Re: C++11 standard not being used Geant4-10.01.p02 Not Logged In (login)
 Next-in-Thread Next-in-Thread
 Next-in-Forum Next-in-Forum

Ok Re: C++11 standard not being used Geant4-10.01.p02 

Forum: Installation and Configuration
Re: Question C++11 standard not being used Geant4-10.01.p02 (Marcus O'Flaherty)
Re: Note Re: C++11 standard not being used Geant4-10.01.p02 (Ben Morgan)
Date: 29 Feb, 2016
From: Marcus O'Flaherty <Marcus O'Flaherty>

Hi Ben,
Thanks for your reply. You're right, I was getting confused between variables for building geant4 with c++11 support and building my application with it. I was convinced I had in fact built Geant4-10.01.p02 with c++11, but adding
message(STATUS "Geant4_CXXSTD=${Geant4_CXXSTD}")
to my CMakeLists.txt returns
-- Geant4_CXXSTD=c++98
so that'll be the problem. Thanks a lot for your help!

 Add Message Add Message
to: "Re: C++11 standard not being used Geant4-10.01.p02"

 Subscribe Subscribe

This site runs SLAC HyperNews version 1.11-slac-98, derived from the original HyperNews


[ Geant 4 Home | Geant 4 HyperNews | Search | Request New Forum | Feedback ]