Message: Geant4.10.2 on CentOS 7 Not Logged In (login)
 Next-in-Thread Next-in-Thread
 Next-in-Forum Next-in-Forum

Warning Geant4.10.2 on CentOS 7 

Forum: Installation and Configuration
Date: 14 Jan, 2016
From: Andrea <Andrea>

Hi all,

from Installation Guide Sec. 1.1:

<<
 Geant4 is officially supported on the following operating system and compiler combinations:

    [...]
    Linux CentOS 7 with gcc 4.8.4 (system compiler), 64bit. 
>>

However, CentOS 7 is shipped with CMake==2.8 ONLY, while the release 10.2 requires CMake >= 3.

[I incidentally tried to change the required version on CMakeLists.txt and got

CMake Error at cmake/Modules/Geant4MacroLibraryTargets.cmake:111 (target_compile_features):
   Unknown CMake command "target_compile_features".
 Call Stack (most recent call first):
   cmake/Modules/Geant4MacroLibraryTargets.cmake:300 (GEANT4_LIBRARY_TARGET)
   source/analysis/CMakeLists.txt:30 (GEANT4_GLOBAL_LIBRARY_TARGET)

]

Cheers, Andrea

Inline Depth:
 1 1
 All All
Outline Depth:
 1 1
 2 2
 All All
Add message: (add)

1 Note: Re: Geant4.10.2 on CentOS 7   (Ben Morgan - 15 Jan, 2016)
(_ Ok: Re: Geant4.10.2 on CentOS 7   (Andrea - 15 Jan, 2016)
 Add Message Add Message
to: "Geant4.10.2 on CentOS 7"

 Subscribe Subscribe

This site runs SLAC HyperNews version 1.11-slac-98, derived from the original HyperNews


[ Geant 4 Home | Geant 4 HyperNews | Search | Request New Forum | Feedback ]