Message: Re: Problem installing Geant4 on 64 bit Windows 10 with VS Express 2015 Not Logged In (login)
 Next-in-Thread Next-in-Thread
 Next-in-Forum Next-in-Forum

None Re: Problem installing Geant4 on 64 bit Windows 10 with VS Express 2015 

Forum: Installation and Configuration
Re: Question Problem installing Geant4 on 64 bit Windows 10 with VS Express 2015 (Piotr Kalaczyński)
Date: 30 Nov, 2015
From: Ben Morgan <Ben Morgan>

On Tue, 24 Nov 2015 21:45:28 GMT, Piotr Kalaczy&#324;ski wrote:
> Hello,
> 
> I have been trying for some time now to install Geant4 on my laptop
> running on 64-bit Windows 10 (upgraded from 8.1). I could not really
> find a single topic on Win10 installation here, so I take it that it is
> either simply too new system and noone tried that yet, or it works
> fine/similar to previous versions for everyone else.
> 
> Nevertheless, I could not successfully build Geant4. I manage to
> generate build in Cmake without getting any errors in there (although to
> get rid of 2 warnings in advanced mode I had to manually specify the
> location of 2 .dll files (visible on the screens)). All the errors just
> pop out when building the project in VS Express.
> 
> I have also tried to circumvent the problem by installing Ubuntu
> alongside my system, but apparently the Ubuntu installer does not see
> any OS on my laptop, thus not allowing me to do this. I know that I
> could theoretically do it "manually", but I would rather not mingle that
> much with my partitions etc.
> 
> My OS and software: Microsoft Windows 10 Home (10.0.10586 N/A Build
> 10586) x64 MS Visual Studio Express 2015 for Windows Desktop Version
> 14.0.23107.0 D14REL Cmake 3.4.0
> 
> I also attach my whole Cmake configuration and the output from VS that I
> get after building.
> 
> I would be very grateful if someone could make any sense of the errors I
> get or at least point me in the right direction.
> 
>    Attachment:
>       http://hypernews.slac.stanford.edu/HyperNews/geant4/get/AUX/2015/11/24/13.26-3080-CmakeConfiguration.pdf
>       http://hypernews.slac.stanford.edu/HyperNews/geant4/get/AUX/2015/11/24/13.26-88874-VisualStudioScreen.PNG
>       http://hypernews.slac.stanford.edu/HyperNews/geant4/get/AUX/2015/11/24/13.26-25875-Output.pdf
>       http://hypernews.slac.stanford.edu/HyperNews/geant4/get/AUX/2015/11/24/13.26-31572-ErrorList.pdf
>       http://hypernews.slac.stanford.edu/HyperNews/geant4/get/AUX/2015/11/24/13.26-89157-WarningList.pdf
> 

I can't be of direct help here on the error messages, but similar ones were reported here:

The new release of Geant4, version 10.2 will be out at the end of this week, and this is tested on VS2015 (albeit on Win7). It may be worth trying this when released.

Cheers,

Ben

 Add Message Add Message
to: "Re: Problem installing Geant4 on 64 bit Windows 10 with VS Express 2015"

 Subscribe Subscribe

This site runs SLAC HyperNews version 1.11-slac-98, derived from the original HyperNews


[ Geant 4 Home | Geant 4 HyperNews | Search | Request New Forum | Feedback ]