Message: Installing G4.10.01.p02 on Yosemite - G4RTXScanner issue Not Logged In (login)
 Next-in-Thread Next-in-Thread
 Next-in-Forum Next-in-Forum

None Installing G4.10.01.p02 on Yosemite - G4RTXScanner issue 

Forum: Installation and Configuration
Date: 17 Sep, 2015
From: Alan James Bell <Alan James Bell>

Hi guys, I'm having trouble installing G4 on my Macbook running Yosemite. I am using the CMake method as described here: http://geant4.web.cern.ch/geant4/UserDocumentation/UsersGuides/InstallationGuide/html/ch02.html

When I do 'make install', it fails at 96% with errors relating to G4RTXScanner.cc. Specifically, the errors are of the like: undeclared identifier 'XOpenDisplay'.

My Cmake command included the switches for INSTALL_DATA=ON, USE_OPENGL=ON, USE_QT=ON. I've also tried without enabling anything.

There was only one failure during configuration, which was checking the size of off64_t.

I'm using: Xcode 6.4. Compiler Apple LLVM version 6.1.0 (clang-602.0.53) . Cmake 3.3.1 Qt 4.8.7 XQuartz 2.7.7

Please let me know if you need more information. Any help will be greatly appreciated.

Regards, Alan.

 Add Message Add Message
to: "Installing G4.10.01.p02 on Yosemite - G4RTXScanner issue"

 Subscribe Subscribe

This site runs SLAC HyperNews version 1.11-slac-98, derived from the original HyperNews


[ Geant 4 Home | Geant 4 HyperNews | Search | Request New Forum | Feedback ]