Message: Re: QT visualization not working Genat4 10.1 Not Logged In (login)
 Next-in-Thread Next-in-Thread
 Next-in-Forum Next-in-Forum

None Re: QT visualization not working Genat4 10.1 

Forum: Installation and Configuration
Re: None QT visualization not working Genat4 10.1 (Ish Mukul)
Date: 17 Jun, 2015
From: Hubert Hu <Hubert Hu>

Hi Ish,

Have you got any further luck with the problem? I've got the exact same problem.

My configuration is: windows 7 pro 64bit Visual studio 2013 express cmake 3.2.3-win32-x86 qt 4.8.6 vs2010 x86 Geant4.10.1 p0.1

With this combination, the geant4 can be successfully compiled. But same as your case when I run the exampleB1, the visual part has a memory access error. In the command line, the example runs fine.

Then I notice that the qt4.8.6 is designed for vs2010 not vs2013. So I try to use qt 5.3.0 vs2013 x86. This times the cmake complains. The error message is the cmake 3.2.3 doesn't support beyond qt4. Then I go to download the cmake 3.3.0-rc2 which is a release candidate. It can support qt5. However I still have errors in compiling the Geant4 source code. This time the error is about the openGL. I can paste the error code later.

It is really a pain in neck for compiling Geant4 under windows platform. The version between these tools has to match very well. I've spent almost every night over last one and half week trying to installed it in my new machine.

By the way, I have VS2013 express and VS2010 pro installed. I couldn't select the vs2010 in cmake. It reports error as the example compilation test failed. If I uninstall the vs2013 and only uses the VS2010, I still have problem. And I discovered that the problem may be link to the fact that I've installed office 2013, which uses the latest .net framework.

Hope anyone can shine some light on this windows installation business.

Thanks,

Hubert

Inline Depth:
 1 1
 All All
Outline Depth:
 1 1
 2 2
 All All
Add message: (add)

1 None: Re: QT visualization not working Genat4 10.1   (Ish Mukul - 17 Jun, 2015)
 Add Message Add Message
to: "Re: QT visualization not working Genat4 10.1"

 Subscribe Subscribe

This site runs SLAC HyperNews version 1.11-slac-98, derived from the original HyperNews


[ Geant 4 Home | Geant 4 HyperNews | Search | Request New Forum | Feedback ]